summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gnuconfig/gnuconfig-20050602.ebuild')
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20050602.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-devel/gnuconfig/gnuconfig-20050602.ebuild b/sys-devel/gnuconfig/gnuconfig-20050602.ebuild
new file mode 100644
index 000000000000..5053996b48cf
--- /dev/null
+++ b/sys-devel/gnuconfig/gnuconfig-20050602.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-20050602.ebuild,v 1.1 2005/06/16 23:01:00 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Updated config.sub and config.guess file from GNU"
+HOMEPAGE="ftp://ftp.gnu.org/pub/gnu/config"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~ppc-macos ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${WORKDIR}"/*.patch
+}
+
+src_compile() { :;}
+
+src_test() {
+ make SHELL=/bin/sh check || die "make check failed :("
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins config.{sub,guess} || die
+ fperms +x /usr/share/${PN}/config.{sub,guess}
+ dodoc ChangeLog
+}