summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb-apple/gdb-apple-563.ebuild')
-rw-r--r--sys-devel/gdb-apple/gdb-apple-563.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/sys-devel/gdb-apple/gdb-apple-563.ebuild b/sys-devel/gdb-apple/gdb-apple-563.ebuild
index 3a7e41fe20d4..1a942500a61d 100644
--- a/sys-devel/gdb-apple/gdb-apple-563.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-563.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-563.ebuild,v 1.1 2009/06/21 10:38:25 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-563.ebuild,v 1.2 2010/03/05 16:25:26 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic
@@ -22,10 +24,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${PV}/src
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${P}-darwin7.patch
epatch "${FILESDIR}"/${P}-no-64bit.patch
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
@@ -34,18 +33,15 @@ src_unpack() {
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
}
-src_compile() {
+src_configure() {
replace-flags -O? -O2
econf \
--disable-werror \
$(use_enable nls) \
|| die
- emake || die
}
src_install() {
- local ED=${ED-${D}}
-
emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
rm -r "${D}"/nukeme || die
rm -Rf "${ED}"/usr/${CHOST} || die