summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc-hppa64')
-rw-r--r--sys-devel/gcc-hppa64/ChangeLog8
-rw-r--r--sys-devel/gcc-hppa64/Manifest4
-rw-r--r--sys-devel/gcc-hppa64/files/digest-gcc-hppa64-3.3.21
-rw-r--r--sys-devel/gcc-hppa64/files/gcc-3.3.2-gentoo-branding.patch18
-rw-r--r--sys-devel/gcc-hppa64/gcc-hppa64-3.3.2.ebuild104
-rw-r--r--sys-devel/gcc-hppa64/metadata.xml8
6 files changed, 143 insertions, 0 deletions
diff --git a/sys-devel/gcc-hppa64/ChangeLog b/sys-devel/gcc-hppa64/ChangeLog
new file mode 100644
index 000000000000..3e008b63bd92
--- /dev/null
+++ b/sys-devel/gcc-hppa64/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sys-devel/gcc-hppa64
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-hppa64/ChangeLog,v 1.1 2004/01/03 18:49:19 gmsoft Exp $
+
+*gcc-hppa64-3.3.2 (03 Jan 2004)
+
+ 03 Jan 2004; Guy Martin <gmsoft@gentoo.org> gcc-hppa64-3.3.2 :
+ First commit of gcc for hppa64. This one will compile 64 bit kernels.
diff --git a/sys-devel/gcc-hppa64/Manifest b/sys-devel/gcc-hppa64/Manifest
new file mode 100644
index 000000000000..e878a6f86304
--- /dev/null
+++ b/sys-devel/gcc-hppa64/Manifest
@@ -0,0 +1,4 @@
+MD5 001233c3709b6668d9a2201e9dbc02c6 ChangeLog 397
+MD5 5fd341e522651617875c363183278b96 gcc-hppa64-3.3.2.ebuild 2228
+MD5 006481ae255582fae4fa22107dfb359e files/digest-gcc-hppa64-3.3.2 64
+MD5 d9ae122db2768f8e504dfef256d4991f files/gcc-3.3.2-gentoo-branding.patch 874
diff --git a/sys-devel/gcc-hppa64/files/digest-gcc-hppa64-3.3.2 b/sys-devel/gcc-hppa64/files/digest-gcc-hppa64-3.3.2
new file mode 100644
index 000000000000..77fbcb74b416
--- /dev/null
+++ b/sys-devel/gcc-hppa64/files/digest-gcc-hppa64-3.3.2
@@ -0,0 +1 @@
+MD5 65999f654102f5438ac8562d13a6eced gcc-3.3.2.tar.bz2 23585904
diff --git a/sys-devel/gcc-hppa64/files/gcc-3.3.2-gentoo-branding.patch b/sys-devel/gcc-hppa64/files/gcc-3.3.2-gentoo-branding.patch
new file mode 100644
index 000000000000..d3b34c72ab66
--- /dev/null
+++ b/sys-devel/gcc-hppa64/files/gcc-3.3.2-gentoo-branding.patch
@@ -0,0 +1,18 @@
+diff -Naurp gcc-3.3.orig/gcc/version.c gcc-3.3/gcc/version.c
+--- gcc-3.3.orig/gcc/version.c 2003-05-13 17:26:03.000000000 -0400
++++ gcc-3.3/gcc/version.c 2003-05-16 14:35:08.000000000 -0400
+@@ -6,7 +6,7 @@
+ please modify this string to indicate that, e.g. by putting your
+ organization's name in parentheses at the end of the string. */
+
+-const char version_string[] = "3.3.2";
++const char version_string[] = "3.3.2 @GENTOO@";
+
+ /* This is the location of the online document giving instructions for
+ reporting bugs. If you distribute a modified version of GCC,
+@@ -15,4 +15,4 @@ const char version_string[] = "3.3";
+ forward us bugs reported to you, if you determine that they are
+ not bugs in your modifications.) */
+
+-const char bug_report_url[] = "<URL:http://gcc.gnu.org/bugs.html>";
++const char bug_report_url[] = "<URL:http://bugs.gentoo.org/>";
diff --git a/sys-devel/gcc-hppa64/gcc-hppa64-3.3.2.ebuild b/sys-devel/gcc-hppa64/gcc-hppa64-3.3.2.ebuild
new file mode 100644
index 000000000000..4ed820c86f91
--- /dev/null
+++ b/sys-devel/gcc-hppa64/gcc-hppa64-3.3.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-hppa64/gcc-hppa64-3.3.2.ebuild,v 1.1 2004/01/03 18:49:19 gmsoft Exp $
+
+
+# Variables
+MYARCH="$(echo ${PN} | cut -d- -f2)"
+TMP_P="${P/-${MYARCH}/}"
+TMP_PN="${PN/-${MYARCH}/}"
+I="/usr"
+S="${WORKDIR}/${P}"
+
+
+DESCRIPTION="Gcc for 64bit hppa kernels"
+HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${TMP_P}/${TMP_P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="-* ~hppa"
+
+DEPEND="virtual/glibc
+ >=sys-devel/binutils-2.14.90.0.7
+ >=sys-devel/gcc-config-1.3.1"
+
+RDEPEND="virtual/glibc
+ >=sys-devel/gcc-config-1.3.1
+ >=sys-libs/zlib-1.1.4
+ >=sys-apps/texinfo-4.2-r4
+ !build? ( >=sys-libs/ncurses-5.2-r2 )"
+
+TARGET=hppa64-linux
+
+version_patch() {
+ [ ! -f "$1" ] && return 1
+ [ -z "$2" ] && return 1
+
+ sed -e "s:@GENTOO@:$2:g" ${1} > ${T}/${1##*/}
+ epatch ${T}/${1##*/}
+}
+
+src_unpack() {
+ unpack ${TMP_P}.tar.bz2
+ cd ${WORKDIR}
+ ln -s ${TMP_P} ${P}
+ cd ${S}
+
+ # Make gcc's version info specific to Gentoo
+ if [ -z "${PP_VER}" ]; then
+ version_patch ${FILESDIR}/${TMP_P}-gentoo-branding.patch \
+ "(Gentoo Linux ${PVR})" || die "Failed Branding"
+ fi
+}
+
+src_compile() {
+ cd ${WORKDIR}
+
+ # Build in a separate build tree
+ mkdir -p ${WORKDIR}/build
+ cd ${WORKDIR}/build
+
+ einfo "Configuring GCC..."
+
+ addwrite "/dev/zero"
+ ${S}/configure --prefix=${I} \
+ --build=hppa-linux \
+ --host=hppa-linux \
+ --disable-shared \
+ --without-libc \
+ --enable-languages=c \
+ --target=${TARGET} \
+ ${myconf} || die
+
+ einfo "Building GCC..."
+ S="${WORKDIR}/build" \
+ emake CPATH=/usr/include CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ # Do allow symlinks in ${I}/lib/gcc-lib/${CHOST}/${PV}/include as
+ # this can break the build.
+ for x in cd ${WORKDIR}/build/gcc/include/*
+ do
+ if [ -L ${x} ]
+ then
+ rm -f ${x}
+ fi
+ done
+
+ einfo "Installing GCC..."
+ # Do the 'make install' from the build directory
+ cd ${WORKDIR}/build
+ S="${WORKDIR}/build" \
+ make prefix=${D}${I} \
+ FAKE_ROOT="${D}" \
+ install || die
+
+ #Remove unneeded files
+
+ for i in lib/libiberty.a man share include info
+ do
+ rm -R ${D}/usr/${i}
+ done
+}
diff --git a/sys-devel/gcc-hppa64/metadata.xml b/sys-devel/gcc-hppa64/metadata.xml
new file mode 100644
index 000000000000..8977bec19344
--- /dev/null
+++ b/sys-devel/gcc-hppa64/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>hppa</herd>
+<longdescription>
+gcc for 64bit kernel on hppa
+</longdescription>
+</pkgmetadata>