summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/bin86/bin86-0.16.16.ebuild')
-rw-r--r--sys-devel/bin86/bin86-0.16.16.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sys-devel/bin86/bin86-0.16.16.ebuild b/sys-devel/bin86/bin86-0.16.16.ebuild
index a17f1cbb9723..3d23b9301f00 100644
--- a/sys-devel/bin86/bin86-0.16.16.ebuild
+++ b/sys-devel/bin86/bin86-0.16.16.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/bin86-0.16.16.ebuild,v 1.2 2005/01/16 11:19:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/bin86-0.16.16.ebuild,v 1.3 2005/01/27 04:00:16 vapier Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Assembler and loader used to create kernel bootsector"
HOMEPAGE="http://www.cix.co.uk/~mayday/"
@@ -22,7 +24,12 @@ src_unpack() {
}
src_compile() {
- emake PREFIX="/usr" CFLAGS="${CFLAGS} -D_POSIX_SOURCE" || die
+ emake \
+ PREFIX="/usr" \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -D_POSIX_SOURCE" \
+ LDFLAGS="${LDFLAGS}" \
+ || die
}
src_install() {