summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/baselayout/ChangeLog5
-rw-r--r--sys-apps/baselayout/baselayout-1.8.6.13.ebuild8
2 files changed, 10 insertions, 3 deletions
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index 07cf59e2f486..b795d8d04424 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for sys-apps/baselayout
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.117 2004/02/08 15:08:58 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.118 2004/02/09 04:12:24 brad_mssw Exp $
# See the gentoo-src rc-scripts ChangeLog for up-to-date release information:
# http://www.gentoo.org/cgi-bin/viewcvs.cgi/rc-scripts/ChangeLog?rev=HEAD&cvsroot=gentoo-src&content-type=text/vnd.viewcvs-markup
+ 08 Feb 2004; Brad House <brad_mssw@gentoo.org> baselayout-1.8.6.13.ebuild:
+ ppc64 fixes
+
*baselayout-1.8.6.13 (08 Feb 2004)
08 Feb 2004; Martin Schlemmer <azarah@gentoo.org>
diff --git a/sys-apps/baselayout/baselayout-1.8.6.13.ebuild b/sys-apps/baselayout/baselayout-1.8.6.13.ebuild
index 5c0674b5cf02..2faedf12663f 100644
--- a/sys-apps/baselayout/baselayout-1.8.6.13.ebuild
+++ b/sys-apps/baselayout/baselayout-1.8.6.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.8.6.13.ebuild,v 1.2 2004/02/08 23:44:52 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.8.6.13.ebuild,v 1.3 2004/02/09 04:12:24 brad_mssw Exp $
# This ebuild needs to be merged "live". You can't simply make a package
# of it and merge it later.
@@ -173,6 +173,10 @@ create_dev_nodes() {
einfo "Using generic-powerpc to make device nodes..."
${D}/sbin/MAKEDEV generic-powerpc
;;
+ ppc64)
+ einfo "Using generic-powerpc to make device nodes..."
+ ${D}/sbin/MAKEDEV generic-powerpc
+ ;;
sparc)
einfo "Using generic-sparc to make device nodes..."
${D}/sbin/MAKEDEV generic-sparc
@@ -216,7 +220,7 @@ src_install() {
# Symlinks so that LSB compliant apps work
# /lib64 is especially required since its the default place for ld.so
- if [ "${ARCH}" = "amd64" ]
+ if [ "${ARCH}" = "amd64" -o "${ARCH}" = "ppc64" ]
then
dosym lib /lib64
dosym lib /usr/lib64