summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/tcb')
-rw-r--r--sys-apps/tcb/ChangeLog6
-rw-r--r--sys-apps/tcb/files/digest-tcb-0.9.8.31
-rw-r--r--sys-apps/tcb/tcb-0.9.8.3.ebuild32
3 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/tcb/ChangeLog b/sys-apps/tcb/ChangeLog
index cca7ed8ad3e5..0801ec293aee 100644
--- a/sys-apps/tcb/ChangeLog
+++ b/sys-apps/tcb/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2002/02/05 00:57:47 gbevin Exp
+*tcb-0.9.8.3 (18 Dec 2002)
+
+ 18 Dec 2002; Joachim Blaabjerg <styx@gentoo.org> tcb-0.9.8.3.ebuild :
+
+ New version, ~x86 masked.
+
*tcb-0.9.7.4 (13 Aug 2002)
13 Aug 2002; Joachim Blaabjerg <styx@gentoo.org> tcb-0.9.7.4.ebuild :
diff --git a/sys-apps/tcb/files/digest-tcb-0.9.8.3 b/sys-apps/tcb/files/digest-tcb-0.9.8.3
new file mode 100644
index 000000000000..50aeda0f69d7
--- /dev/null
+++ b/sys-apps/tcb/files/digest-tcb-0.9.8.3
@@ -0,0 +1 @@
+MD5 63b68b9ea4cdfc45fa6869bac5074cb0 tcb-0.9.8.3.tar.gz 35776
diff --git a/sys-apps/tcb/tcb-0.9.8.3.ebuild b/sys-apps/tcb/tcb-0.9.8.3.ebuild
new file mode 100644
index 000000000000..8d32e197a4c3
--- /dev/null
+++ b/sys-apps/tcb/tcb-0.9.8.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tcb/tcb-0.9.8.3.ebuild,v 1.1 2002/12/18 14:53:59 styx Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Libraries and tools implementing the tcb password shadowing scheme."
+SRC_URI="ftp://ftp.openwall.com/pub/projects/tcb/${P}.tar.gz"
+HOMEPAGE="http://www.openwall.com"
+LICENSE="GPL-2"
+
+DEPEND=">=sys-libs/pam-0.75"
+SLOT="0"
+KEYWORDS="~x86"
+
+pkg_preinst() {
+ # might want to add these into baselayout eventually...
+ for group in auth chkpwd shadow; do
+ if ! grep -q ^${group}: /etc/group ; then
+ groupadd ${group} || die "problem adding group $group"
+ fi
+ done
+}
+
+src_compile () {
+ emake || die
+}
+
+src_install () {
+ make FAKEROOT=${D} install || die
+ dodoc ChangeLog LICENSE
+}