summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/lshw/lshw-01.04a.ebuild')
-rw-r--r--sys-apps/lshw/lshw-01.04a.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/lshw/lshw-01.04a.ebuild b/sys-apps/lshw/lshw-01.04a.ebuild
new file mode 100644
index 000000000000..2be47776706d
--- /dev/null
+++ b/sys-apps/lshw/lshw-01.04a.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lshw/lshw-01.04a.ebuild,v 1.1 2003/11/04 23:54:12 mholzer Exp $
+
+inherit flag-o-matic
+
+MAJ_PV=${PV:0:5}
+MIN_PVE=${PV:5:7}
+MIN_PV=${MIN_PVE/a/A}
+
+MY_P="$PN-$MIN_PV.$MAJ_PV"
+DESCRIPTION="Hardware Lister"
+HOMEPAGE="http://ezix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ezix/${MY_P}.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc"
+IUSE=""
+
+DEPEND="virtual/glibc"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ # cpuid.cc uses inline asm and can not be linked when
+ # position independent code is desired.
+ filter-flags -fPIC
+ has_version 'sys-devel/hardened-gcc' && append-flags -yet_exec
+ emake CXXFLAGS="${CXXFLAGS}" || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}