summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/kbd/kbd-1.15.1.ebuild')
-rw-r--r--sys-apps/kbd/kbd-1.15.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/kbd/kbd-1.15.1.ebuild b/sys-apps/kbd/kbd-1.15.1.ebuild
new file mode 100644
index 000000000000..75f718c3e99c
--- /dev/null
+++ b/sys-apps/kbd/kbd-1.15.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/kbd-1.15.1.ebuild,v 1.1 2009/10/11 01:22:48 vapier Exp $
+
+inherit autotools
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="http://freshmeat.net/projects/kbd/"
+SRC_URI="ftp://ftp.altlinux.org/pub/people/legion/kbd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf # stupid tarball lacks generated autotools
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+ dohtml doc/*.html
+}