summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/diffutils/diffutils-2.8.4-r1.ebuild')
-rw-r--r--sys-apps/diffutils/diffutils-2.8.4-r1.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild b/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild
deleted file mode 100644
index 3293bfc208a1..000000000000
--- a/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild,v 1.11 2003/09/07 02:28:11 msterret Exp $
-
-IUSE="nls build"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Tools to make diffs and compare files"
-SRC_URI="ftp://alpha.gnu.org/gnu/diffutils/${P}.tar.gz"
-HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
-
-KEYWORDS="x86 amd64 ppc sparc alpha mips hppa"
-SLOT="0"
-LICENSE="GPL-2"
-
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )
- !build? ( sys-apps/texinfo )"
-
-RDEPEND="virtual/glibc"
-
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- if [ -n "`use build`" ]
- then
- #disable texinfo building so we can remove the dep
- cp Makefile.in Makefile.in.orig
- sed -e 's:SUBDIRS = doc:SUBDIRS =:' \
- Makefile.in.orig > Makefile.in
- fi
-
- # Build fails with make -j5 or greater on pentium4. This is because
- # the jobs creating the opjects, which depend on paths.h is sheduled
- # at the same time paths.h is generated. This patch just fix a small
- # typeo that caused this. This closes bug #8934.
- # <azarah@gentoo.org> (14 Oct 2002)
- cd ${S}; patch -p1 < ${FILESDIR}/${P}-Makefile-fix-typeo.patch || die
-}
-
-src_compile() {
- local myconf=""
- [ -z "`use nls`" ] && myconf="--disable-nls"
-
- econf --build=${CHOST} \
- ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr \
- datadir=${D}/usr/share \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
-
- if [ -z "`use build`" ]
- then
- dodoc COPYING ChangeLog NEWS README
- else
- rm -rf ${D}/usr/share/info
- fi
-}
-