summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch')
-rw-r--r--sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch15
1 files changed, 10 insertions, 5 deletions
diff --git a/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch b/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
index 941cb3bd39da..6636484f876e 100644
--- a/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
+++ b/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
@@ -1,10 +1,14 @@
---- spectromatic-1.0/Makefile 2002-03-30 05:17:34.000000000 +0000
-+++ spectromatic-1.0.new/Makefile 2008-11-26 10:43:15.910065276 +0000
+Respect LDFLAGS, CFLAGS, CC #334715
+Fix install paths
+
+--- Makefile
++++ Makefile
@@ -1,33 +1,29 @@
# Makefile for spectromatic
-CFLAGS = -O2 -Wall
- LIBS = -lgsl -lgslcblas -lpng -lm
+-LIBS = -lgsl -lgslcblas -lpng -lm
++LIBS = -lpng `pkg-config --libs gsl`
DESTDIR =
TOPLEVEL_HOME = /usr
@@ -23,10 +27,11 @@
- install -o root -g root -m 0644 man/spectromatic.1 $(DESTDIR)$(TOPLEVEL_HOME)/man/man1
-
all: $(OBJ)
- $(CC) -o $(TARGET) $(OBJ) $(LIBS)
+- $(CC) -o $(TARGET) $(OBJ) $(LIBS)
- strip $(TARGET)
++ $(CC) $(LDFLAGS) -o $(TARGET) $(OBJ) $(LIBS)
+
-+install: all
++install: $(TARGET)
+ mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/bin
+ mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/share/man/man1
+ install -m 0755 spectromatic $(DESTDIR)$(TOPLEVEL_HOME)/bin