summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/gwyddion/gwyddion-1.16.ebuild')
-rw-r--r--sci-visualization/gwyddion/gwyddion-1.16.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-visualization/gwyddion/gwyddion-1.16.ebuild b/sci-visualization/gwyddion/gwyddion-1.16.ebuild
new file mode 100644
index 000000000000..23e4fedac73a
--- /dev/null
+++ b/sci-visualization/gwyddion/gwyddion-1.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/gwyddion-1.16.ebuild,v 1.1 2006/07/15 22:06:48 cryos Exp $
+
+DESCRIPTION="A software framework for SPM data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python perl ruby nls"
+
+DEPEND="virtual/opengl
+ python? ( virtual/python )
+ perl? ( dev-lang/perl )
+ ruby? ( virtual/ruby )
+ >=x11-libs/gtk+-2.6
+ x11-libs/gtkglext"
+
+src_compile() {
+ econf \
+ $(use_enable python) \
+ $(use_enable perl) \
+ $(use_enable ruby) \
+ $(use_enable nls) \
+ --disable-desktop-file-update \
+ || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed."
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}