summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libgeotiff/libgeotiff-1.2.1-r1.ebuild')
-rw-r--r--sci-libs/libgeotiff/libgeotiff-1.2.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/libgeotiff/libgeotiff-1.2.1-r1.ebuild b/sci-libs/libgeotiff/libgeotiff-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..5948ef3cb99a
--- /dev/null
+++ b/sci-libs/libgeotiff/libgeotiff-1.2.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeotiff/libgeotiff-1.2.1-r1.ebuild,v 1.1 2005/02/21 00:00:01 nerdboy Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Library for reading TIFF files with embedded tags for geographic (cartographic) information"
+HOMEPAGE="http://remotesensing.org/geotiff/geotiff.html"
+SRC_URI="ftp://ftp.remotesensing.org/pub/geotiff/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~hppa ~mips ~alpha ~amd64 ~ppc ~ppc64"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=media-libs/tiff-3.7.0
+ sci-libs/proj"
+
+src_compile() {
+ append-flags -fPIC
+ econf || die
+ emake -j1 || die
+}
+
+src_install() {
+ dobin bin/{listgeo,geotifcp,makegeo} || die
+ insinto usr/include
+ dolib.a libgeotiff.a
+ dolib.so libgeotiff.so.${PV}
+ dosym libgeotiff.so.${PV} usr/lib/libgeotiff.so
+ doins libxtiff/*.h
+ doins *.h
+ doins *.inc
+ insinto usr/share/epsg_csv
+ doins csv/*.csv
+}