summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/kicad/kicad-20070525.ebuild')
-rw-r--r--sci-electronics/kicad/kicad-20070525.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-electronics/kicad/kicad-20070525.ebuild b/sci-electronics/kicad/kicad-20070525.ebuild
index 9b53ef26848b..f309d03f5839 100644
--- a/sci-electronics/kicad/kicad-20070525.ebuild
+++ b/sci-electronics/kicad/kicad-20070525.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070525.ebuild,v 1.6 2007/12/12 09:17:27 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070525.ebuild,v 1.7 2007/12/12 11:08:52 leio Exp $
inherit wxwidgets
@@ -21,11 +21,11 @@ pkg_setup() {
# Tell wxwidgets.eclass which version we need
WX_GTK_VER="2.6"
- # Check for proper wxGTK USE flags.
+ # Ask for the correct wxGTK configuration
if use unicode; then
- need-wxwidgets unicode || die "You need to install wxGTK with unicode support."
+ need-wxwidgets unicode
else
- need-wxwidgets X || die "You need to install wxGTK with X support."
+ need-wxwidgets ansi
fi
built_with_use "=x11-libs/wxGTK-${WX_GTK_VER}*" opengl || die "You need to install wxGTK with opengl support."
}