summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostap/Manifest6
-rw-r--r--net-wireless/hostap/files/digest-hostap-0.0.15
-rw-r--r--net-wireless/hostap/hostap-0.0.1.ebuild160
-rw-r--r--net-wireless/hostap/hostap-20021012-r1.ebuild3
4 files changed, 170 insertions, 4 deletions
diff --git a/net-wireless/hostap/Manifest b/net-wireless/hostap/Manifest
index 39f766e2c01b..817a874044e2 100644
--- a/net-wireless/hostap/Manifest
+++ b/net-wireless/hostap/Manifest
@@ -1,6 +1,6 @@
-MD5 ace91c71ea1d76a6b3451fbf74864929 hostap-0.0.1.ebuild 4302
-MD5 27a066c996cfd542fbd5a3e30116a2a2 hostap-20021012-r1.ebuild 4470
-MD5 ae9531cb64d4b9273947fedabcf084c4 ChangeLog 2086
+MD5 1792c1d78c928fa0e303eb5c36860bf3 hostap-0.0.1.ebuild 4295
+MD5 7cd580b2e05ad8cb3910b8e7cdb9ace5 hostap-20021012-r1.ebuild 4470
+MD5 36cb3684ad7a3e3085a4f37de5f8b47e ChangeLog 2086
MD5 423cd360c12fa0a6530fb01f334a0bd6 files/digest-hostap-0.0.1 354
MD5 72d2af56025069ea611a9cc8456ef12e files/hostap-20021012-gentoo-patch.diff 517
MD5 6e519f92b3d38795a4280e3970daf89c files/digest-hostap-20021012-r1 510
diff --git a/net-wireless/hostap/files/digest-hostap-0.0.1 b/net-wireless/hostap/files/digest-hostap-0.0.1
new file mode 100644
index 000000000000..cee7e7357bdf
--- /dev/null
+++ b/net-wireless/hostap/files/digest-hostap-0.0.1
@@ -0,0 +1,5 @@
+MD5 a4706881461f5702cb9c1144cb61566b hostap-0.0.1.tar.gz 253207
+MD5 7e9f01a697d2e3e5164340d79474ea30 pcmcia-cs-3.2.1.tar.gz 1250413
+MD5 24e8c68d0eac2a9b3446acdd259c22a0 pcmcia-cs-3.2.1-3.2.2.diff.gz 246919
+MD5 9ed9491a743b7400b382b199377c7279 pcmcia-cs-3.2.1-3.2.3.diff.gz 247541
+MD5 c94ce648d1e420be0cf02246236dc387 pcmcia-cs-3.2.1-3.2.4.diff.gz 305171
diff --git a/net-wireless/hostap/hostap-0.0.1.ebuild b/net-wireless/hostap/hostap-0.0.1.ebuild
new file mode 100644
index 000000000000..a95cf188ebd8
--- /dev/null
+++ b/net-wireless/hostap/hostap-0.0.1.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/hostap-0.0.1.ebuild,v 1.1 2003/04/15 19:18:56 latexer Exp $
+
+inherit eutils
+
+DESCRIPTION="HostAP wireless drivers"
+HOMEPAGE="http://hostap.epitest.fi/"
+
+MY_PCMCIA="pcmcia-cs-3.2.1"
+PATCH_3_2_2="${MY_PCMCIA}-3.2.2.diff.gz"
+PATCH_3_2_3="${MY_PCMCIA}-3.2.3.diff.gz"
+PATCH_3_2_4="${MY_PCMCIA}-3.2.4.diff.gz"
+
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz
+ pcmcia? ( mirror://sourceforge/pcmcia-cs/${MY_PCMCIA}.tar.gz )
+ pcmcia? ( mirror://gentoo/${PATCH_3_2_2} )
+ pcmcia? ( mirror://gentoo/${PATCH_3_2_3} )
+ pcmcia? ( mirror://gentoo/${PATCH_3_2_4} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="pcmcia"
+
+DEPEND=">=net-wireless/wireless-tools-25
+ pcmcia? ( >=sys-apps/pcmcia-cs-3.2.1* )"
+
+LIB_PATH="/lib/modules/${KV}"
+
+if [ x"${HOSTAP_DRIVERS}" = x ]; then
+ CUSTOM="no"
+else
+ CUSTOM="yes"
+fi
+
+src_unpack() {
+ check_KV
+ unpack ${P}.tar.gz
+
+ if [ -n "`use pcmcia`" ]; then
+ unpack ${MY_PCMCIA}.tar.gz
+ cd ${WORKDIR}/${MY_PCMCIA}
+ if [ -z "`has_version =sys-apps/pcmcia-cs-3.2.4*`" ]; then
+ epatch ${DISTDIR}/${PATCH_3_2_4}
+ elif [ -z "`has_version =sys-apps/pcmcia-cs-3.2.3*`" ]; then
+ epatch ${DISTDIR}/${PATCH_3_2_3}
+ elif [ -z "`has_version =sys-apps/pcmcia-cs-3.2.2*`" ]; then
+ epatch ${DISTDIR}/${PATCH_3_2_2}
+ fi
+ fi
+
+
+ cd ${S}
+ mv Makefile ${T}
+ sed -e "s:gcc:${CC}:" \
+ -e "s:-O2:${CFLAGS}:" \
+ -e "s:\$(EXTRA_CFLAGS):\$(EXTRA_CFLAGS) -DPRISM2_HOSTAPD:" \
+ ${T}/Makefile > Makefile
+
+ if [ -n "`use pcmcia`" ] || [[ "${HOSTAP_DRIVERS}" == *pccard* ]]; then
+ mv Makefile ${T}
+ sed -e "s:^PCMCIA_PATH=:PCMCIA_PATH=${WORKDIR}/${MY_PCMCIA}:" \
+ ${T}/Makefile > Makefile
+ fi
+
+ cd ${S}/hostapd
+ mv Makefile ${T}
+ sed -e "s:gcc:${CC}:" \
+ -e "s:-O2:${CFLAGS}:" \
+ ${T}/Makefile > Makefile
+}
+
+src_compile() {
+ #
+ # This ebuild now uses a system similar to the alsa ebuild.
+ # By default, it will install the pci and plx drivers, and
+ # the pcmcia drivers if pcmcia is in your use variables. To
+ # specify exactly which drivers to build, do something like
+ #
+ # HOSTAP_DRIVERS="pci pccard" emerge hostap
+ #
+ # Available options are pci, plx, and pccard.
+ #
+ # If you experience problems compiling the hostap_pci module,
+ # try disabling CONFIG_MODVERSION from your kernel.
+ #
+
+ if [ "${CUSTOM}" == yes ]; then
+ einfo "Building the folowing drivers: ${HOSTAP_DRIVERS}"
+ emake ${HOSTAP_DRIVERS} hostap crypt || die
+ else
+ if [ -n "`use pcmcia`" ]; then
+ einfo "Building the folowing drivers: pci plx pccard"
+ emake pci plx pccard || die
+ else
+ einfo "Building the folowing drivers: pci plx"
+ emake ${HOSTAP_DRIVERS} || die
+ fi
+ fi
+
+ cd ${S}/hostapd
+ emake || die
+}
+
+src_install() {
+ dodir ${LIB_PATH}/net
+ cp ${S}/driver/modules/{hostap.o,hostap_crypt.o,hostap_crypt_wep.o}\
+ ${D}${LIB_PATH}/net/
+
+ if [ "${CUSTOM}" == "no" ]; then
+
+ if [ -n "`use pcmcia`" ]; then
+ dodir ${LIB_PATH}/pcmcia
+ dodir /etc/pcmcia
+ cp ${S}/driver/modules/hostap_cs.o ${D}/${LIB_PATH}/pcmcia/
+ cp ${S}/driver/etc/hostap_cs.conf ${D}/etc/pcmcia/
+ if [ -r /etc/pcmcia/prism2.conf ]; then
+ einfo "You may need to edit or remove /etc/pcmcia/prism2.conf"
+ einfo "This is usually a result of conflicts with the"
+ einfo "linux-wlan-ng drivers."
+ fi
+ fi
+ for driver in ${HOSTAP_DRIVERS}; do
+ cp ${S}/driver/modules/hostap_${driver}.o\
+ ${D}${LIB_PATH}/net/;
+ done
+ elif [ "${CUSTOM}" == "yes" ]; then
+ if [[ "${HOSTAP_DRIVERS}" = *pccard* ]]; then
+ dodir ${LIB_PATH}/pcmcia
+ dodir /etc/pcmcia
+ cp ${S}/driver/modules/hostap_cs.o ${D}/${LIB_PATH}/pcmcia/
+ cp ${S}/driver/etc/hostap_cs.conf ${D}/etc/pcmcia/
+ if [ -r /etc/pcmcia/prism2.conf ]; then
+ einfo "You may need to edit or remove /etc/pcmcia/prism2.conf"
+ einfo "This is usually a result of conflicts with the"
+ einfo "linux-wlan-ng drivers."
+ fi
+ fi
+
+ if [[ "${HOSTAP_DRIVERS}" = *pci* ]]; then
+ cp ${S}/driver/modules/hostap_pci.o\
+ ${D}${LIB_PATH}/net/
+ fi
+
+ if [[ "${HOSTAP_DRIVERS}" = *plx* ]]; then
+ cp ${S}/driver/modules/hostap_plx.o\
+ ${D}${LIB_PATH}/net/
+ fi
+
+ fi
+
+ dodoc FAQ README README.prism2 ChangeLog
+
+ dosbin hostapd/hostapd
+}
+pkg_postinst(){
+ /sbin/depmod -a
+}
diff --git a/net-wireless/hostap/hostap-20021012-r1.ebuild b/net-wireless/hostap/hostap-20021012-r1.ebuild
index b6dfc1d9e665..d93dba95bf61 100644
--- a/net-wireless/hostap/hostap-20021012-r1.ebuild
+++ b/net-wireless/hostap/hostap-20021012-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/hostap-20021012-r1.ebuild,v 1.10 2003/04/07 00:28:03 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/hostap-20021012-r1.ebuild,v 1.11 2003/04/15 19:18:56 latexer Exp $
inherit eutils
@@ -41,6 +41,7 @@ src_unpack() {
unpack ${PN}-2002-10-12.tar.gz
if [ -n "`use pcmcia`" ]; then
+ check_KV
unpack ${MY_PCMCIA}.tar.gz
cd ${WORKDIR}/${MY_PCMCIA}
if [ -z "`has_version =sys-apps/pcmcia-cs-3.2.4*`" ]; then