summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/dansguardian/dansguardian-2.8.0.2.ebuild')
-rw-r--r--net-proxy/dansguardian/dansguardian-2.8.0.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-proxy/dansguardian/dansguardian-2.8.0.2.ebuild b/net-proxy/dansguardian/dansguardian-2.8.0.2.ebuild
new file mode 100644
index 000000000000..b900a4454d20
--- /dev/null
+++ b/net-proxy/dansguardian/dansguardian-2.8.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/dansguardian/dansguardian-2.8.0.2.ebuild,v 1.1 2005/04/22 19:15:11 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="Web content filtering via proxy"
+HOMEPAGE="http://dansguardian.org"
+SRC_URI="http://mirror.dansguardian.org/downloads/2/Stable/${P}.source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~sparc ~ppc ppc64"
+IUSE=""
+DEPEND="!net-proxy/dansguardian-dgav
+ virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/dansguardian-xnaughty-2.7.6-1.diff
+}
+
+src_compile() {
+ ./configure \
+ --prefix= \
+ --installprefix=${D} \
+ --mandir=/usr/share/man/ \
+ --cgidir=/var/www/localhost/cgi-bin/ || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ if [ -d "/etc/logrotate.d" ]; then mkdir -p ${D}/etc/logrotate.d; fi
+ make install || die "make install failed"
+
+ dodir /etc/init.d
+ cp ${FILESDIR}/dansguardian.init ${D}/etc/init.d/dansguardian
+
+ rm -rf ${D}/etc/rc.d
+
+ einfo "Fixing location of initscript"
+ sed 's/rc.d\///' ${D}/etc/dansguardian/logrotation > ${D}/etc/dansguardian/logrotation.fixed
+ mv -f ${D}/etc/dansguardian/logrotation.fixed ${D}/etc/dansguardian/logrotation
+
+ dodoc INSTALL README LICENSE
+}