summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/pavuk/pavuk-0.9.32.ebuild')
-rw-r--r--net-misc/pavuk/pavuk-0.9.32.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/net-misc/pavuk/pavuk-0.9.32.ebuild b/net-misc/pavuk/pavuk-0.9.32.ebuild
deleted file mode 100644
index e0d8fbf59d3c..000000000000
--- a/net-misc/pavuk/pavuk-0.9.32.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/pavuk-0.9.32.ebuild,v 1.8 2006/11/18 04:17:57 compnerd Exp $
-
-inherit eutils
-
-DESCRIPTION="Web spider and website mirroring tool"
-HOMEPAGE="http://www.pavuk.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc sparc x86"
-IUSE="ssl X gnome mozilla nls"
-
-DEPEND=">=sys-apps/sed-4
- sys-devel/gettext
- sys-libs/zlib
- ssl? ( dev-libs/openssl )
- mozilla? ( www-client/mozilla )"
-
-src_compile() {
- econf \
- --enable-threads \
- --with-regex=auto \
- --disable-gtk \
- --disable-socks \
- $(use_enable ssl) \
- $(use_enable mozilla js) \
- $(use_enable nls) \
- || die "econf failed"
-
- emake || die
-}
-
-src_install() {
- # fix sandbox violation for gnome .desktop and icon, and gnome menu entry
- if use gnome
- then
- sed -i 's:GNOME_PREFIX = /usr:GNOME_PREFIX = ${D}usr:' Makefile
- sed -i 's:GNOME_PREFIX = /usr:GNOME_PREFIX = ${D}usr:' icons/Makefile
- sed -i 's:Type=Internet:Type=Application:' pavuk.desktop
- fi
-
- make install DESTDIR=${D}
-
- dodoc README CREDITS FAQ NEWS AUTHORS BUGS \
- TODO MAILINGLIST ChangeLog wget-pavuk.HOWTO jsbind.txt \
- pavuk_authinfo.sample pavukrc.sample
-}