summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/atftp/atftp-0.7.ebuild')
-rw-r--r--net-misc/atftp/atftp-0.7.ebuild31
1 files changed, 15 insertions, 16 deletions
diff --git a/net-misc/atftp/atftp-0.7.ebuild b/net-misc/atftp/atftp-0.7.ebuild
index df6b8d5547e6..baa176a59e24 100644
--- a/net-misc/atftp/atftp-0.7.ebuild
+++ b/net-misc/atftp/atftp-0.7.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/atftp/atftp-0.7.ebuild,v 1.9 2005/02/07 15:17:14 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/atftp/atftp-0.7.ebuild,v 1.10 2005/02/07 21:11:03 vapier Exp $
+
+inherit eutils
DESCRIPTION="Advanced TFTP implementation client/server"
HOMEPAGE="ftp://ftp.mamalinux.com/pub/atftp/"
@@ -8,29 +10,26 @@ SRC_URI="ftp://ftp.mamalinux.com/pub/atftp/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc arm ~amd64"
+KEYWORDS="~amd64 arm ~ppc ~sparc ~x86"
IUSE="tcpd"
DEPEND="tcpd? ( sys-apps/tcp-wrappers )
!virtual/tftp"
PROVIDE="virtual/tftp"
-src_compile () {
- econf `use_enable tcpd libwrap` || die "./configure failed"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc.patch
+}
- sed -i \
- -e "/^CFLAGS =/s:-g::" \
- -e "/^CFLAGS =/s:-O2::" \
- -e "/^CFLAGS =/s:$: ${CFLAGS}:" \
- Makefile
- emake || die
+src_compile() {
+ econf $(use_enable tcpd libwrap) || die "./configure failed"
+ emake CFLAGS="${CFLAGS} -D_REENTRANT" || die
}
src_install() {
- make install DESTDIR=${D} || die "Installation failed"
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/atftp.init atftp
- insinto /etc/conf.d
- newins ${FILESDIR}/atftp.confd atftp
+ make install DESTDIR="${D}" || die "Installation failed"
+ newinitd ${FILESDIR}/atftp.init atftp
+ newconfd ${FILESDIR}/atftp.confd atftp
}