summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog8
-rw-r--r--net-libs/rb_libtorrent/Manifest4
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.12.1.ebuild50
3 files changed, 60 insertions, 2 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 0f06f4c3bed9..c72c7ff5f58c 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.38 2008/01/09 19:50:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.39 2008/02/04 13:52:56 armin76 Exp $
+
+*rb_libtorrent-0.12.1 (04 Feb 2008)
+
+ 04 Feb 2008; Raúl Porcel <armin76@gentoo.org>
+ +rb_libtorrent-0.12.1.ebuild:
+ Version bump
*rb_libtorrent-0.13_pre1912 (09 Jan 2008)
diff --git a/net-libs/rb_libtorrent/Manifest b/net-libs/rb_libtorrent/Manifest
index 55a6ef2c1fbd..ca66c8e5cb56 100644
--- a/net-libs/rb_libtorrent/Manifest
+++ b/net-libs/rb_libtorrent/Manifest
@@ -1,6 +1,8 @@
+DIST libtorrent-0.12.1.tar.gz 1188288 RMD160 cafb097a2b8a76777eb7a229cfbeb4113081a42e SHA1 4c405008b78a7b54099fce848dbb9f1a2f7782fe SHA256 0db29ea807dfd682bed5992950c35c40e8a53a4c5b2f383b8d071c4bfb9f64db
DIST libtorrent-0.12.tar.gz 1176469 RMD160 b59310214186b9b644e5e638fe1aff92e90842f9 SHA1 c0b0535100d53452719cdfbcdf8e66c1217bc29e SHA256 0663f9adaa9d90334ebf78eb6f5b31074ff533d7bec5d3325ff98baad5b7df07
DIST libtorrent-0.13_pre1912.tar.bz2 1424997 RMD160 cf5e5ee007bbabf542db8fef31947e8f421f9cea SHA1 33a0c5151aede968f88ef2510c539d66834714d6 SHA256 43773cbfe804f776958847b9cbd2aab43413f0d49d40ab29ba676592b68ecf7a
+EBUILD rb_libtorrent-0.12.1.ebuild 1457 RMD160 63c67cab7580bd0cb0e68ca765b8dddb5b991aa8 SHA1 7a80f49e17d9b75251aff79923a31d079562a738 SHA256 a672097e26865b4b0cebae69b3c2247ae1a5bad566101d91fbaf763704f15535
EBUILD rb_libtorrent-0.12.ebuild 1453 RMD160 25ecfb33f7cb613d8a72ab4c1348eef5c17f095b SHA1 46f45a8e5f02093397c6d217f83e0753d6486e2c SHA256 eaf35b46743e88b299ed8d77d69ec06ec1759785b0d7977cb6b9cffc743bbe44
EBUILD rb_libtorrent-0.13_pre1912.ebuild 1476 RMD160 162ff90c97e54dfea6f99849e1d74ff0e94fa237 SHA1 3a860b55ed99411e49f4cfa525c518d850dbfd3d SHA256 4ea83a9ff87a25c969b078f8ab0876f860e6387cbe2ed548971f4331ddf90690
-MISC ChangeLog 6312 RMD160 a64636e3d2358e3894fd10753583febd4a50eed9 SHA1 223b27c01f95ed6ccbcff805181d8c5385849f60 SHA256 c6552839eb13a498f10af596c901a74310fa7624fab28e963c0b02c316c912b0
+MISC ChangeLog 6446 RMD160 aaabab2fa43bc77e7fded692558251cb70d6d234 SHA1 19fb11903d9e3e3f5b413eb5b7d074e951529d45 SHA256 d14962336dac725628d062de85fedf4c3a2d33da7e0ac67418a76d54c0565e45
MISC metadata.xml 222 RMD160 0dc4b04f31dcc89402f87c352327fe327b3cf31f SHA1 540337d5841f15b43186e5858f9e24032567de08 SHA256 713b9d1548682d5c1c3686a7b0711acf065a8fa4f386883ace90359d3dceb966
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.12.1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.12.1.ebuild
new file mode 100644
index 000000000000..614661a17e15
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.12.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.12.1.ebuild,v 1.1 2008/02/04 13:52:56 armin76 Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit eutils autotools
+
+MY_P="${P/rb_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="mirror://sourceforge/libtorrent/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND="dev-libs/boost
+ !net-libs/libtorrent"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ # We need boost built with threads
+ if ! has_version ">=dev-libs/boost-1.34_pre20061214" && \
+ ! built_with_use "dev-libs/boost" threads; then
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
+ fi
+}
+
+src_compile() {
+ BOOST_LIBS="--with-boost-date-time=boost_date_time-mt \
+ --with-boost-filesystem=boost_filesystem-mt \
+ --with-boost-thread=boost_thread-mt \
+ --with-boost-regex=boost_regex-mt \
+ --with-boost-program_options=boost_program_options-mt"
+
+ econf $(use_enable debug) \
+ ${BOOST_LIBS} \
+ LDFLAGS="${LDFLAGS} -pthread" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog AUTHORS NEWS README
+}