summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libisds/libisds-9999.ebuild')
-rw-r--r--net-libs/libisds/libisds-9999.ebuild36
1 files changed, 22 insertions, 14 deletions
diff --git a/net-libs/libisds/libisds-9999.ebuild b/net-libs/libisds/libisds-9999.ebuild
index 830559645975..47f24886a362 100644
--- a/net-libs/libisds/libisds-9999.ebuild
+++ b/net-libs/libisds/libisds-9999.ebuild
@@ -1,46 +1,54 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/libisds-9999.ebuild,v 1.1 2010/06/29 14:03:45 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/libisds-9999.ebuild,v 1.2 2010/06/29 14:21:08 scarabeus Exp $
EAPI=3
-[[ ${PV} = 9999* ]] && GIT="git"
+[[ ${PV} = 9999* ]] && GIT="git autotools"
EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
-inherit base autotools ${GIT}
+inherit base ${GIT}
-DESCRIPTION="Client library to access ISDS Soap service"
-HOMEPAGE="http://www.abclinuxu.cz/datove-schranky/libisds"
+DESCRIPTION="Client library for accessing ISDS Soap services"
+HOMEPAGE="http://xpisar.wz.cz/libisds/"
if [[ ${PV} = 9999* ]]; then
SRC_URI=""
KEYWORDS=""
else
- SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.bz2"
+ SRC_URI="http://xpisar.wz.cz/libisds/dist/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="LGPL-2"
SLOT="0"
-IUSE="debug test"
+IUSE="debug nls static-libs test"
-RDEPEND="
+COMMON_DEPEND="
+ app-crypt/gpgme
dev-libs/expat
dev-libs/libgcrypt
dev-libs/libxml2
net-misc/curl[ssl]
"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig
- sys-devel/gettext"
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-crypt/gnupg-2
+"
+
+DOCS=( "NEWS" "README" "AUTHORS" "ChangeLog" )
src_prepare() {
base_src_prepare
- eautoreconf
+ [[ ${PV} = 9999* ]] && eautoreconf
}
src_configure() {
econf \
--disable-fatalwarnings \
- $(use_enable test) \
- $(use_enable debug)
-
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable test)
}