summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/vyqchat/vyqchat-0.2.3.ebuild')
-rw-r--r--net-irc/vyqchat/vyqchat-0.2.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-irc/vyqchat/vyqchat-0.2.3.ebuild b/net-irc/vyqchat/vyqchat-0.2.3.ebuild
new file mode 100644
index 000000000000..14a964ae9bad
--- /dev/null
+++ b/net-irc/vyqchat/vyqchat-0.2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/vyqchat/vyqchat-0.2.3.ebuild,v 1.1 2003/12/28 20:32:03 zul Exp $
+
+DESCRIPTION="QT based Vypress Chat clone for X."
+HOMEPAGE="http://linux.bydg.org/~yogin/"
+SRC_URI="http://linux.bydg.org/~yogin/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="arts"
+
+DEPEND=">=qt-3.0
+ arts? ( kde-base/arts )"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf
+
+ epatch ${FILESDIR}/vyqchat_packet_id.patch
+
+ use arts && myconf="--with-arts"
+ ./configure --host=${CHOST} \
+ --prefix=/usr --infodir=/usr/share/info \
+ --mandir=/usr/share/man --with-x \
+ --with-Qt-dir=/usr/qt/3 ${myconf} || die "./configure failed"
+ make || die
+}
+
+src_install() {
+ einstall || die
+ dodoc README THANKS NEWS
+}