summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/onis/onis-0.6.1.ebuild')
-rw-r--r--net-irc/onis/onis-0.6.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-irc/onis/onis-0.6.1.ebuild b/net-irc/onis/onis-0.6.1.ebuild
new file mode 100644
index 000000000000..9f2eb2df20b1
--- /dev/null
+++ b/net-irc/onis/onis-0.6.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/onis/onis-0.6.1.ebuild,v 1.1 2004/08/05 23:28:07 swegener Exp $
+
+inherit eutils
+
+DESCRIPTION="onis not irc stats"
+HOMEPAGE="http://verplant.org/onis/"
+SRC_URI="http://verplant.org/${PN}/${P}.tar.bz2"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+DEPEND=">=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/0.6.0-nochdir.patch
+
+ sed -i -e s:lang/:/usr/share/onis/lang/: config
+}
+
+src_install () {
+ eval `perl -V:installprivlib`
+
+ dobin onis
+
+ dodir ${installprivlib}
+ cp -R lib/Onis ${D}/${installprivlib}
+
+ dodir /usr/share/onis
+ cp -R lang reports/* ${D}/usr/share/onis
+
+ dodoc CHANGELOG README THANKS config users.conf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The onis themes have been installed in /usr/share/onis/*-theme"
+ einfo "You can find a sample configuration at /usr/share/doc/${PF}/config.gz"
+ einfo
+}