summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/bobotpp/bobotpp-2.1.4.ebuild')
-rw-r--r--net-irc/bobotpp/bobotpp-2.1.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-irc/bobotpp/bobotpp-2.1.4.ebuild b/net-irc/bobotpp/bobotpp-2.1.4.ebuild
new file mode 100644
index 000000000000..f55983a3f309
--- /dev/null
+++ b/net-irc/bobotpp/bobotpp-2.1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bobotpp/bobotpp-2.1.4.ebuild,v 1.1 2004/07/13 19:13:35 swegener Exp $
+
+DESCRIPTION="A flexible IRC bot scriptable in scheme"
+HOMEPAGE="http://savannah.nongnu.org/projects/bobotpp/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="guile"
+
+DEPEND="guile? ( dev-util/guile )"
+
+src_compile() {
+ econf $(use_enable guile scripting) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+
+ dosym bobot++.info /usr/share/info/bobotpp.info
+
+ dodoc AUTHORS ChangeLog NEWS README SCRIPTING TODO
+ dohtml doc/index.html
+
+ docinto example-config
+ dodoc examples/{bot.*,scripts.load}
+
+ docinto example-scripts
+ dodoc scripts/{boulet,country,eval,hello,log.scm,tamere,uname,uptime}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can find a sample configuration file set in"
+ einfo "/usr/share/doc/${PF}/example-config"
+ einfo
+}