summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/bnc')
-rw-r--r--net-irc/bnc/ChangeLog6
-rw-r--r--net-irc/bnc/Manifest15
-rw-r--r--net-irc/bnc/bnc-2.9.3-r2.ebuild5
-rw-r--r--net-irc/bnc/files/bnc-2.9.3-64bit.patch20
4 files changed, 31 insertions, 15 deletions
diff --git a/net-irc/bnc/ChangeLog b/net-irc/bnc/ChangeLog
index aa57a1dc196f..c26e566c2cea 100644
--- a/net-irc/bnc/ChangeLog
+++ b/net-irc/bnc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/bnc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/ChangeLog,v 1.24 2005/10/02 22:07:27 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/ChangeLog,v 1.25 2005/10/08 12:11:50 blubb Exp $
+
+ 08 Oct 2005; Simon Stelling <blubb@gentoo.org>
+ +files/bnc-2.9.3-64bit.patch, bnc-2.9.3-r2.ebuild:
+ rekeyword ~amd64 with the patch from bug 106901
02 Oct 2005; Marcus D. Hanwell <cryos@gentoo.org> bnc-2.9.3-r1.ebuild,
bnc-2.9.3-r2.ebuild:
diff --git a/net-irc/bnc/Manifest b/net-irc/bnc/Manifest
index e0fa76ea765d..720867839605 100644
--- a/net-irc/bnc/Manifest
+++ b/net-irc/bnc/Manifest
@@ -1,16 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 ae8e64bd9eee8c8027174e01ef029362 ChangeLog 3529
MD5 d1e5886d87cfe90f8ede10a68de0e6b0 bnc-2.9.3-r1.ebuild 976
-MD5 b6e500407368eade095da7c69ecca20b bnc-2.9.3-r2.ebuild 1027
-MD5 484318c1b48cd6bde219116b258698c0 ChangeLog 3376
+MD5 0230592900cfd7b3857cab0207d91d4b bnc-2.9.3-r2.ebuild 1064
MD5 b2fd9f07925d7c1a3f1ed2366d0c74ba metadata.xml 221
MD5 a6f25e4b520bc1540a80f78bb419d53f files/digest-bnc-2.9.3-r1 59
MD5 a6f25e4b520bc1540a80f78bb419d53f files/digest-bnc-2.9.3-r2 59
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDQForntT9W3vfTuoRAiziAJ9iIgVwPfQ2Lmfe6d22byy7NZFACQCePMkq
-bL/N55os45mmjp4uY20gUxE=
-=JPeL
------END PGP SIGNATURE-----
+MD5 2f9e8261e9af06984792f0ee03ab40c2 files/bnc-2.9.3-64bit.patch 402
diff --git a/net-irc/bnc/bnc-2.9.3-r2.ebuild b/net-irc/bnc/bnc-2.9.3-r2.ebuild
index 67bae70b0efc..2a1d2fe6ddd1 100644
--- a/net-irc/bnc/bnc-2.9.3-r2.ebuild
+++ b/net-irc/bnc/bnc-2.9.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.9.3-r2.ebuild,v 1.2 2005/10/02 22:07:27 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bnc/bnc-2.9.3-r2.ebuild,v 1.3 2005/10/08 12:11:50 blubb Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="http://gotbnc.com/files/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha -amd64 ~arm ~ppc ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86"
IUSE="ssl"
DEPEND="virtual/libc
@@ -22,6 +22,7 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
sed -i -e s:./mkpasswd:/usr/bin/bncmkpasswd: ${S}/bncsetup || die
+ epatch ${FILESDIR}/${P}-64bit.patch
}
src_compile() {
diff --git a/net-irc/bnc/files/bnc-2.9.3-64bit.patch b/net-irc/bnc/files/bnc-2.9.3-64bit.patch
new file mode 100644
index 000000000000..0eb94a4817ce
--- /dev/null
+++ b/net-irc/bnc/files/bnc-2.9.3-64bit.patch
@@ -0,0 +1,20 @@
+--- bnc2.9.3-orig/server.c 2005-02-07 01:29:11.000000000 +0000
++++ bnc2.9.3/server.c 2005-09-22 18:10:18.000000000 +0100
+@@ -398,7 +398,7 @@
+ int send_queued(struct lsock *ls)
+ {
+ int res;
+- int length;
++ size_t length;
+ char *msg;
+
+ while(sbuf_getlength(&ls->sendq) > 0)
+@@ -1114,7 +1114,7 @@
+ int dccsend(int fd, struct sbuf *sendq)
+ {
+ int res;
+- int length;
++ size_t length;
+ char *msg;
+
+