summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/kadu/kadu-0.4.1.ebuild')
-rw-r--r--net-im/kadu/kadu-0.4.1.ebuild60
1 files changed, 30 insertions, 30 deletions
diff --git a/net-im/kadu/kadu-0.4.1.ebuild b/net-im/kadu/kadu-0.4.1.ebuild
index 1aac4d4254cc..84aaec2eff97 100644
--- a/net-im/kadu/kadu-0.4.1.ebuild
+++ b/net-im/kadu/kadu-0.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/kadu-0.4.1.ebuild,v 1.6 2006/11/13 15:08:04 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kadu/kadu-0.4.1.ebuild,v 1.7 2007/02/11 18:16:25 flameeyes Exp $
inherit flag-o-matic eutils
@@ -41,7 +41,7 @@ IUSE="X debug alsa arts esd voice speech nas oss spell ssl tcltk xosd amarok ext
DEPEND="=x11-libs/qt-3*
media-libs/libsndfile
- alsa? ( media-libs/alsa-lib virtual/alsa )
+ alsa? ( media-libs/alsa-lib )
arts? ( kde-base/arts )
amarok? ( media-sound/amarok )
esd? ( media-sound/esound )
@@ -57,23 +57,23 @@ SRC_URI="http://kadu.net/download/stable/${P}.tar.bz2
amarok? ( http://scripts.one.pl/amarok/stable/0.4.0/amarok-${VAMAROK}.tar.gz )
tcltk? ( http://scripts.one.pl/tcl4kadu/files/snapshots/tcl_scripting-${VTCL}.tar.gz )
extraicons? (
- http://biprowod.wroclaw.pl/kadu/kadu-theme-alt_cryst.tar.bz2
- http://www.kadu.net/download/additions/kadu-theme-crystal-16.tar.bz2
- http://www.kadu.net/download/additions/kadu-theme-crystal-22.tar.bz2
- http://www.kadu.net/download/additions/kadu-theme-gg3d.tar.bz2
- http://www.kadu.net/download/additions/kadu-theme-noia-16.tar.bz2
- http://www.kadu.net/download/additions/kadu-theme-nuvola-16.tar.gz
- http://www.kadu.net/download/additions/kadu-theme-nuvola-22.tar.gz
- http://www.kadu.net/download/additions/kadu-theme-old_default.tar.bz2
- http://www.kadu.net/download/additions/kadu-theme-piolnet.tar.bz2
- http://www.kadu.net/download/additions/kadu-theme-real_gg.tar.bz2 )
+ http://biprowod.wroclaw.pl/kadu/kadu-theme-alt_cryst.tar.bz2
+ http://www.kadu.net/download/additions/kadu-theme-crystal-16.tar.bz2
+ http://www.kadu.net/download/additions/kadu-theme-crystal-22.tar.bz2
+ http://www.kadu.net/download/additions/kadu-theme-gg3d.tar.bz2
+ http://www.kadu.net/download/additions/kadu-theme-noia-16.tar.bz2
+ http://www.kadu.net/download/additions/kadu-theme-nuvola-16.tar.gz
+ http://www.kadu.net/download/additions/kadu-theme-nuvola-22.tar.gz
+ http://www.kadu.net/download/additions/kadu-theme-old_default.tar.bz2
+ http://www.kadu.net/download/additions/kadu-theme-piolnet.tar.bz2
+ http://www.kadu.net/download/additions/kadu-theme-real_gg.tar.bz2 )
extramodules? (
- http://pcb45.tech.us.edu.pl/~blysk/weather/weather-${WEATHER}.tar.bz2
- http://nkg.republika.pl/files/ext_info-${EXT_INFO}.tar.bz2
- http://biprowod.wroclaw.pl/kadu/inne/spy-${SPY}.tar.gz
- http://users.skorpion.wroc.pl/arturmat/firewall/files/firewall-${FIREWALL}.tar.bz2
- http://biprowod.wroclaw.pl/kadu/KaduChess-${CHESS}.tar.bz2
- http://pcb45.tech.us.edu.pl/~blysk/led_notify/led_notify-${LED_NOTIFY}.tar.bz2
+ http://pcb45.tech.us.edu.pl/~blysk/weather/weather-${WEATHER}.tar.bz2
+ http://nkg.republika.pl/files/ext_info-${EXT_INFO}.tar.bz2
+ http://biprowod.wroclaw.pl/kadu/inne/spy-${SPY}.tar.gz
+ http://users.skorpion.wroc.pl/arturmat/firewall/files/firewall-${FIREWALL}.tar.bz2
+ http://biprowod.wroclaw.pl/kadu/KaduChess-${CHESS}.tar.bz2
+ http://pcb45.tech.us.edu.pl/~blysk/led_notify/led_notify-${LED_NOTIFY}.tar.bz2
http://scripts.one.pl/screenshot/stable/0.4.0/screenshot-${SSVER}.tar.gz )
xosd? ( http://www.kadu.net/~joi/xosd_notify/xosd_notify-${XOSD_NOTIFY}.tar.bz2 )
mail? ( http://michal.kernel-panic.cjb.net/mail/tars/release/mail-${MAIL}.tar.bz2 )
@@ -86,8 +86,8 @@ S=${WORKDIR}/${PN}
enable_module() {
if use ${1}; then
- mv ${WORKDIR}/${2} ${WORKDIR}/kadu/modules/
- module_config ${2} m
+ mv ${WORKDIR}/${2} ${WORKDIR}/kadu/modules/
+ module_config ${2} m
fi
}
@@ -189,17 +189,17 @@ src_compile() {
# Some fixes
einfo "Fixing modules spec files"
if use arts; then
- spec_config arts_sound MODULE_INCLUDES_PATH "\"$(kde-config --prefix)/include $(kde-config --prefix)/include/artsc\""
- spec_config arts_sound MODULE_LIBS_PATH $(kde-config --prefix)/lib
+ spec_config arts_sound MODULE_INCLUDES_PATH "\"$(kde-config --prefix)/include $(kde-config --prefix)/include/artsc\""
+ spec_config arts_sound MODULE_LIBS_PATH $(kde-config --prefix)/lib
fi
if use amarok; then
- spec_config amarok MODULE_INCLUDES_PATH $(kde-config --prefix)/include
- spec_config amarok MODULE_LIBS_PATH $(kde-config --prefix)/lib
+ spec_config amarok MODULE_INCLUDES_PATH $(kde-config --prefix)/include
+ spec_config amarok MODULE_LIBS_PATH $(kde-config --prefix)/lib
fi
if use extramodules; then
- einfo "Changing default firewall log location to user's homedir/.gg/firewall.log"
- sed ${WORKDIR}/firewall.tcl -i -e 's%$module(scriptpath)/firewall.log%$env(HOME)/.gg/firewall.log%g'
+ einfo "Changing default firewall log location to user's homedir/.gg/firewall.log"
+ sed ${WORKDIR}/firewall.tcl -i -e 's%$module(scriptpath)/firewall.log%$env(HOME)/.gg/firewall.log%g'
fi
local myconf
@@ -220,7 +220,7 @@ src_install() {
# Installing additional scripts and plugins
# Chess and Firewall
if use extramodules; then
- if use tcltk; then
+ if use tcltk; then
einfo "Installing Chess script"
insinto /usr/share/kadu/modules/data/tcl_scripting/scripts
doins ${WORKDIR}/KaduChess/{data,pics,KaduChess.tcl}
@@ -229,11 +229,11 @@ src_install() {
einfo "Installing Firewall module"
doins ${WORKDIR}/firewall{.tcl,.png}
- fi
+ fi
fi
if use extraicons; then
- einfo "Installing extra icons"
+ einfo "Installing extra icons"
for theme in ${THEMES}; do
insinto /usr/share/kadu/themes/icons/${theme}
doins ${WORKDIR}/${theme}/{icons.conf,*.png}