summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/firehol/firehol-1.250-r1.ebuild')
-rw-r--r--net-firewall/firehol/firehol-1.250-r1.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/net-firewall/firehol/firehol-1.250-r1.ebuild b/net-firewall/firehol/firehol-1.250-r1.ebuild
new file mode 100644
index 000000000000..eeb9c79a88d2
--- /dev/null
+++ b/net-firewall/firehol/firehol-1.250-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firehol/firehol-1.250-r1.ebuild,v 1.1 2007/04/26 21:13:56 centic Exp $
+
+inherit eutils
+
+DESCRIPTION="iptables firewall generator"
+HOMEPAGE="http://firehol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-1.226.tar.bz2"
+
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+
+DEPEND="sys-apps/iproute2"
+RDEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ virtual/modutils
+ || (
+ net-misc/wget
+ net-misc/curl
+ )"
+
+S="${WORKDIR}/${PN}-1.226"
+
+pkg_setup() {
+ # Bug 81600 fail if iproute2 is built with minimal
+ if built_with_use sys-apps/iproute2 minimal; then
+ eerror "Firehol requires iproute2 to be emerged without"
+ eerror "the USE-Flag \"minimal\"."
+ eerror "Re-emerge iproute2 with"
+ eerror "USE=\"-minimal\" emerge sys-apps/iproute2"
+ die "sys-apps/iproute2 without USE=\"minimal\" needed"
+ fi
+}
+
+# patch for embedded Gentoo - GNAP
+# backport from firehol-CVS.
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+ epatch ${FILESDIR}/firehol-1.226-to-228.patch || die
+ epatch ${FILESDIR}/firehol-1.226-to-250.patch || die
+ epatch ${FILESDIR}/${P}-groupwith.patch || die
+ epatch ${FILESDIR}/${P}-printf.patch || die
+}
+
+src_install() {
+ newsbin firehol.sh firehol
+
+ dodir /etc/firehol /etc/firehol/examples /etc/firehol/services
+ insinto /etc/firehol/examples
+ doins examples/* || die
+
+ newconfd ${FILESDIR}/firehol.conf.d firehol || die
+
+ dodoc ChangeLog README TODO WhatIsNew || die
+ dohtml doc/*.html doc/*.css || die
+
+ docinto scripts
+ dodoc get-iana.sh adblock.sh || die
+
+ doman man/*.1 man/*.5 || die
+
+ newinitd ${FILESDIR}/firehol.initrd firehol || die
+}
+
+pkg_postinst() {
+ einfo "The default path to firehol's configuration file is /etc/firehol/firehol.conf"
+ einfo "See /etc/firehol/examples for configuration examples."
+ #
+ # Install a default configuration if none is available yet
+ if [[ ! -e "${ROOT}/etc/firehol/firehol.conf" ]]; then
+ einfo "Installing a sample configuration as ${ROOT}/etc/firehol/firehol.conf"
+ cp "${ROOT}/etc/firehol/examples/client-all.conf" "${ROOT}/etc/firehol/firehol.conf"
+ fi
+}
+