summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/metasploit/ChangeLog7
-rw-r--r--net-analyzer/metasploit/Manifest3
-rw-r--r--net-analyzer/metasploit/metasploit-3.1_p5456.ebuild102
3 files changed, 110 insertions, 2 deletions
diff --git a/net-analyzer/metasploit/ChangeLog b/net-analyzer/metasploit/ChangeLog
index d73a7e896ddd..8a3f27c54024 100644
--- a/net-analyzer/metasploit/ChangeLog
+++ b/net-analyzer/metasploit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/metasploit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.31 2008/03/23 16:02:01 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/ChangeLog,v 1.32 2008/03/24 05:42:42 pva Exp $
+
+*metasploit-3.1_p5456 (24 Mar 2008)
+
+ 24 Mar 2008; Peter Volkov <pva@gentoo.org> +metasploit-3.1_p5456.ebuild:
+ Sync with upstream.
23 Mar 2008; Peter Volkov <pva@gentoo.org> metasploit-2.7.ebuild:
Fixed typo in postrm, bug #214380, thank Denilson for report
diff --git a/net-analyzer/metasploit/Manifest b/net-analyzer/metasploit/Manifest
index a84317d907bf..79cb6561f1c6 100644
--- a/net-analyzer/metasploit/Manifest
+++ b/net-analyzer/metasploit/Manifest
@@ -9,5 +9,6 @@ EBUILD metasploit-2.7.ebuild 1451 RMD160 86b02866587de2829a1905ab274cbe4abdd4199
EBUILD metasploit-3.1.ebuild 2066 RMD160 ab256eefdec3d5b8e8c00dd4f123b70cd947de94 SHA1 f0e9c7e9b965f2fb3af779974c4b905b6d3770e3 SHA256 7b0cd59fccb0bfacac006b727347706f86c785b88136c87db08ee75d0df63e55
EBUILD metasploit-3.1_p5422.ebuild 3655 RMD160 3c6627151e96ee0d8d1eef00202bcdc27e2f36db SHA1 2459d45a40a2017a9bbd382be2479df086a8d6ab SHA256 e71b1896649289578dd2a51d74ac1a7dc455e18b4b092a423c051a1e85b9b0c1
EBUILD metasploit-3.1_p5435.ebuild 3655 RMD160 03fb08385f464e9486a897715cfc2ea45465cc61 SHA1 29836caf04f2c34e549eccc510dbcfade41abc92 SHA256 ab00bc5be5fefabc5710d2626befacd027de5ec320cfb5b7503826db6b141956
-MISC ChangeLog 5281 RMD160 de987067c787578d8d622b528e428132bc4fe2fb SHA1 cd6fcb288c43607766da642864eb2148c7415e18 SHA256 18220f9d8b7102ef5acd98e89220d0747130e533c9c8c29f1ab5e736cad2e799
+EBUILD metasploit-3.1_p5456.ebuild 3655 RMD160 b1f4f3cf4e32e5feff6b4c6ac04de7ad4bd914ac SHA1 1ff6119791680c9e74105f81520e606a70a972ef SHA256 dbfeb25648027472b3e38c7a473f112a7fe6fbdd94e2081acd5755c1d8ed9279
+MISC ChangeLog 5416 RMD160 2e2193dced5b655750b069e1f8c2b83954e1cca8 SHA1 e9577c055398ed5c9efbb772b7a26844a956c557 SHA256 b0157f9e36c0b354b9f36d740d365302e74486e54951a94b211197951a4874ad
MISC metadata.xml 863 RMD160 90c921bdc34bc98f2c43fb75f633dbdeb65561ae SHA1 022699039a88ca8d53bd75d0b20dbd8709953d55 SHA256 594bd50431c2ecc70b0834fed0dbfe28bac86201fb4e5b20989a56baa8f21eff
diff --git a/net-analyzer/metasploit/metasploit-3.1_p5456.ebuild b/net-analyzer/metasploit/metasploit-3.1_p5456.ebuild
new file mode 100644
index 000000000000..805685ed27fe
--- /dev/null
+++ b/net-analyzer/metasploit/metasploit-3.1_p5456.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-3.1_p5456.ebuild,v 1.1 2008/03/24 05:42:42 pva Exp $
+
+MY_P=${PN/metasploit/framework}-${PV}
+
+# Metasploit uses subversion as a *normal* update mechanism for stable branches
+# of the package. This ebuild uses _p<number> inside $PV to install updated up
+# to revision <number> version of framework. For more information, take a look
+# at bug #195924.
+if [[ "${PV}" =~ (_p)([0-9]+) ]] ; then
+ inherit subversion
+ SRC_URI=""
+ MTSLPT_REV=${BASH_REMATCH[2]}
+ ESVN_REPO_URI="https://metasploit.com/svn/framework3/branches/framework-${PV%_p*}/@${MTSLPT_REV}"
+else
+ SRC_URI="http://sugar.metasploit.com/releases/${MY_P}.tar.gz"
+fi
+
+DESCRIPTION="Advanced open-source framework for developing, testing, and using vulnerability exploit code"
+HOMEPAGE="http://www.metasploit.org/"
+
+LICENSE="MSF-1.2"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk sqlite sqlite3 postgres httpd"
+
+RDEPEND="dev-lang/ruby
+ gtk? ( dev-ruby/ruby-libglade2 )
+ httpd? ( =dev-ruby/rails-1.2* )
+ sqlite? ( dev-ruby/sqlite-ruby
+ dev-ruby/activerecord )
+ sqlite3? ( dev-ruby/sqlite3-ruby
+ dev-ruby/activerecord )
+ postgres? ( dev-ruby/ruby-postgres
+ dev-ruby/activerecord )"
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ sed -i -e "s/RAILS_GEM_VERSION = '1.2.2'/RAILS_GEM_VERSION = '1.2'/" \
+ data/msfweb/config/environment.rb || die "sed failed"
+}
+
+src_install() {
+ if [[ "${SRC_URI}" != "" ]] ; then
+ # remove the subversion directories
+ find "${S}" -type d -name ".svn" -print0 | xargs -0 -n1 rm -R
+ fi
+
+ # should be as simple as copying everything into the target...
+ dodir /usr/lib/${PN}${SLOT}
+ cp -R "${S}"/* "${D}"/usr/lib/${PN}${SLOT} || die "Copy files failed"
+ rm -Rf "${D}"/usr/lib/${PN}${SLOT}/documentation "${D}"/usr/lib/${PN}${SLOT}/README
+
+ rm "${S}"/documentation/LICENSE
+ dodir /usr/share/doc/${PF}
+ cp -R "${S}"/{documentation,README} "${D}"/usr/share/doc/${PF}
+
+ dodir /usr/bin/
+ for file in `ls msf*`; do
+ dosym /usr/lib/${PN}${SLOT}/${file} /usr/bin/${file}${SLOT}
+ done
+
+ chown -R root:0 "${D}"
+
+ if use httpd; then
+ newinitd "${FILESDIR}"/msfweb${SLOT}.initd msfweb${SLOT} \
+ || die "newinitd failed"
+ newconfd "${FILESDIR}"/msfweb${SLOT}.confd msfweb${SLOT} \
+ || die "newconfd failed"
+ fi
+}
+
+pkg_postinst() {
+ if [[ "${SRC_URI}" == "" ]] ; then
+ elog "If you wish to update ${PN} manually simply run:"
+ elog
+ elog "ESVN_REVISION=<rev> emerge =${PF}"
+ elog
+ elog "where <rev> is either HEAD (in case you wish to get all updates)"
+ elog "or specific revision number. But NOTE, this update will vanish"
+ elog "next time you reemerge ${PN}. To make update permanent either"
+ elog "create ebuild with specific revision number inside your overlay"
+ elog "or report revision bump bug at http://bugs.gentoo.org ."
+ elog
+ elog "In case you use portage it's also possible to create"
+ elog "/etc/portage/env/${CATEGORY}/${PN} file with ESVN_REVISION=<rev>"
+ elog "content. Then each time you run emerge ${PN} you'll have said"
+ elog "<rev> installed. For example, if you run"
+ elog " # mkdir /etc/portage/env/${CATEGORY}"
+ elog ' # echo "ESVN_REVISION=HEAD" >> /etc/portage/env/${CATEGORY}/${PN}'
+ elog "each time you reemerge ${PN} it'll be updated to get all possible"
+ elog "updates for framework-${PV%_p*} branch."
+ elog "You can do similar things in paludis using /etc/paludis/bashrc."
+ else
+ ewarn "${PN} version you installed is for testing purposes only"
+ ewarn "as it's impossible to update it. For day by day work use"
+ ewarn "different version."
+ fi
+}