summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/snort/snort-2.3.3-r1.ebuild')
-rw-r--r--net-analyzer/snort/snort-2.3.3-r1.ebuild34
1 files changed, 19 insertions, 15 deletions
diff --git a/net-analyzer/snort/snort-2.3.3-r1.ebuild b/net-analyzer/snort/snort-2.3.3-r1.ebuild
index d65ba9e7c2ff..354da74001f8 100644
--- a/net-analyzer/snort/snort-2.3.3-r1.ebuild
+++ b/net-analyzer/snort/snort-2.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.3.3-r1.ebuild,v 1.8 2005/08/23 13:50:11 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.3.3-r1.ebuild,v 1.9 2005/09/17 04:11:28 vanquirius Exp $
inherit eutils gnuconfig flag-o-matic
@@ -42,36 +42,40 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
gnuconfig_update
if use flexresp || use inline ; then
- epatch ${FILESDIR}/2.3.0-libnet-1.0.patch
+ epatch "${FILESDIR}/2.3.0-libnet-1.0.patch"
fi
sed -i "s:var RULE_PATH ../rules:var RULE_PATH /etc/snort/rules:" \
etc/snort.conf || die "sed snort.conf failed"
if use prelude ; then
- epatch ${DISTDIR}/${P}-prelude-0.9.0_rc1.diff.bz2
+ epatch "${WORKDIR}/${P}-prelude-0.9.0_rc1.diff"
sed -i -e "s:AC_PROG_RANLIB:AC_PROG_LIBTOOL:" configure.in \
|| die "sed configure.in failed"
fi
if use sguil ; then
- cd ${S}/src/preprocessors
- epatch ${WORKDIR}/sguil-0.5.3/sensor/snort_mods/2_1/spp_portscan_sguil.patch
- epatch ${WORKDIR}/sguil-0.5.3/sensor/snort_mods/2_1/spp_stream4_sguil.patch
- cd ${S}
+ cd "${S}/src/preprocessors"
+ epatch "${WORKDIR}/sguil-0.5.3/sensor/snort_mods/2_1/spp_portscan_sguil.patch"
+ epatch "${WORKDIR}/sguil-0.5.3/sensor/snort_mods/2_1/spp_stream4_sguil.patch"
+ cd "${S}"
fi
if use snortsam ; then
cd ..
einfo "Applying snortsam patch"
- ./patchsnort.sh ${S} || die "snortsam patch failed"
- cd ${S}
+ ./patchsnort.sh "${S}" || die "snortsam patch failed"
+ cd "${S}"
fi
+ # bug 105852
+ epatch "${FILESDIR}/${P}-log.c.diff"
+
+
einfo "Regenerating autoconf/automake files"
autoreconf -f -i || die "autoreconf failed"
}
@@ -103,7 +107,7 @@ src_install() {
keepdir /var/log/snort/
- dodoc COPYING LICENSE doc/*
+ dodoc LICENSE doc/*
docinto schemas ; dodoc schemas/*
insinto /etc/snort
@@ -115,11 +119,11 @@ src_install() {
use prelude && doins etc/prelude-classification.config
- newinitd ${FILESDIR}/snort.rc6 snort
- newconfd ${FILESDIR}/snort.confd snort
+ newinitd "${FILESDIR}/snort.rc6" snort
+ newconfd "${FILESDIR}/snort.confd" snort
- chown snort:snort ${D}/var/log/snort
- chmod 0770 ${D}/var/log/snort
+ chown snort:snort "${D}/var/log/snort"
+ chmod 0770 "${D}/var/log/snort"
}
pkg_postinst() {