summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/x264-encoder/x264-encoder-0.0.20100118.ebuild')
-rw-r--r--media-video/x264-encoder/x264-encoder-0.0.20100118.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/media-video/x264-encoder/x264-encoder-0.0.20100118.ebuild b/media-video/x264-encoder/x264-encoder-0.0.20100118.ebuild
deleted file mode 100644
index ad3d8abde403..000000000000
--- a/media-video/x264-encoder/x264-encoder-0.0.20100118.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/x264-encoder/x264-encoder-0.0.20100118.ebuild,v 1.1 2010/01/19 11:39:50 aballier Exp $
-
-EAPI=2
-inherit eutils multilib toolchain-funcs versionator
-
-MY_P=x264-snapshot-$(get_version_component_range 3)-2245
-
-DESCRIPTION="A free commandline encoder for X264/AVC streams"
-HOMEPAGE="http://www.videolan.org/developers/x264.html"
-SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug ffmpeg +mp4 +threads"
-
-RDEPEND="mp4? ( >=media-video/gpac-0.4.1_pre20060122 )
- ~media-libs/x264-${PV}
- ffmpeg? ( media-video/ffmpeg )"
-DEPEND="${RDEPEND}
- amd64? ( >=dev-lang/yasm-0.6.2 )
- x86? ( || ( >=dev-lang/yasm-0.6.2 dev-lang/nasm )
- !<dev-lang/yasm-0.6.2 )
- x86-fbsd? ( >=dev-lang/yasm-0.6.2 )
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-nostrip.patch \
- "${FILESDIR}"/${PN}-nolib-20100118.patch
-}
-
-src_configure() {
- tc-export CC
-
- local myconf=""
- use debug && myconf="${myconf} --enable-debug"
-
- ./configure \
- --prefix=/usr \
- --libdir=/usr/$(get_libdir) \
- --disable-avs-input \
- $(use_enable ffmpeg lavf-input) \
- $(use_enable mp4 mp4-output) \
- $(use_enable threads pthread) \
- --extra-asflags="${ASFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- --extra-ldflags="${LDFLAGS}" \
- --host="${CHOST}" \
- ${myconf} \
- || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-}