summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mpfc/mpfc-1.3.2.ebuild')
-rw-r--r--media-sound/mpfc/mpfc-1.3.2.ebuild49
1 files changed, 33 insertions, 16 deletions
diff --git a/media-sound/mpfc/mpfc-1.3.2.ebuild b/media-sound/mpfc/mpfc-1.3.2.ebuild
index aba6fa36112a..8654bda77a90 100644
--- a/media-sound/mpfc/mpfc-1.3.2.ebuild
+++ b/media-sound/mpfc/mpfc-1.3.2.ebuild
@@ -1,38 +1,55 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/mpfc-1.3.2.ebuild,v 1.1 2004/09/29 21:18:45 pkdawson Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/mpfc-1.3.2.ebuild,v 1.2 2004/09/30 02:47:39 eradicator Exp $
+
+IUSE="alsa oss esd mad oggvorbis gpm"
+
+inherit eutils
DESCRIPTION="Music Player For Console"
HOMEPAGE="http://mpfc.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
-
SLOT="0"
-KEYWORDS="~x86"
-IUSE="alsa oss esd mad oggvorbis gpm"
-
+KEYWORDS="~amd64 ~sparc ~x86"
-DEPEND="alsa? ( >=media-libs/alsa-lib-0.9.0 )
+RDEPEND="alsa? ( >=media-libs/alsa-lib-0.9.0 )
esd? ( >=media-sound/esound-0.2.22 )
mad? ( media-libs/libmad )
oggvorbis? ( media-libs/libvorbis )
gpm? ( >=sys-libs/gpm-1.19.3 )"
-src_compile() {
- local myconf=""
- myconf="${myconf} $(use_enable alsa)"
- myconf="${myconf} $(use_enable oss)"
- myconf="${myconf} $(use_enable esd)"
- myconf="${myconf} $(use_enable mad mp3)"
- myconf="${myconf} $(use_enable oggvorbis ogg)"
- myconf="${myconf} $(use_enable gpm)"
+DEPEND="${RDEPEND}
+ sys-apps/findutils
+ sys-apps/grep
+ sys-apps/sed"
+
+src_unpack() {
+ unpack ${A}
+ # $(get_libdir) fixes
+ cd ${S}
+ find . -name 'Makefile.in' |
+ xargs grep ^libdir |
+ cut -f1 -d: |
+ xargs sed -i "s:^\(libdir.*\)/lib/\(.*\)$:\1/$(get_libdir)/\2:" || die
+}
+
+src_compile() {
+ local myconf="
+ $(use_enable alsa) \
+ $(use_enable oss) \
+ $(use_enable esd) \
+ $(use_enable mad mp3) \
+ $(use_enable oggvorbis ogg) \
+ $(use_enable gpm) \
+ --sysconfdir=/etc"
econf ${myconf} || die
- emake || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
insinto /etc
doins mpfcrc