summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/esound')
-rw-r--r--media-sound/esound/ChangeLog6
-rw-r--r--media-sound/esound/esound-0.2.28.ebuild48
-rw-r--r--media-sound/esound/files/digest-esound-0.2.281
3 files changed, 54 insertions, 1 deletions
diff --git a/media-sound/esound/ChangeLog b/media-sound/esound/ChangeLog
index cb10cda6fba1..393708e514c4 100644
--- a/media-sound/esound/ChangeLog
+++ b/media-sound/esound/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/esound
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.9 2002/06/07 19:38:28 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/ChangeLog,v 1.10 2002/06/19 16:32:49 stroke Exp $
+
+*esound-0.2.28 (19 Jun 2002)
+ 19 Jun 2002; Gabriele Giorgetti <stroke@gentoo.org> :
+ New version.
*esound-0.2.27 (07 Jun 2002)
07 Jun 2002; Martin Schlemmer <azarah@gentoo.org> :
diff --git a/media-sound/esound/esound-0.2.28.ebuild b/media-sound/esound/esound-0.2.28.ebuild
new file mode 100644
index 000000000000..385f444adc4a
--- /dev/null
+++ b/media-sound/esound/esound-0.2.28.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/esound/esound-0.2.28.ebuild,v 1.1 2002/06/19 16:32:49 stroke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The Enlightened Sound Daemon"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/esound/${P}.tar.bz2
+ftp://download.sourceforge.net/pub/mirrors/gnome/stable/sources/esound/${P}.tar.bz2"
+HOMEPAGE="http://www.tux.org/~ricdude/EsounD.html"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ >=media-libs/audiofile-0.1.9
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+
+RDEPEND="virtual/glibc
+ >=media-libs/audiofile-0.1.9
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )"
+
+src_compile() {
+ libtoolize --copy --force
+
+ local myconf=""
+ use tcpd && myconf="${myconf} --with-libwrap" \
+ || myconf="${myconf} --without-libwrap"
+
+ use alsa && myconf="${myconf} --enable-alsa" \
+ || myconf="${myconf} --enable-alsa=no"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/esd \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ make prefix=${D}/usr sysconfdir=${D}/etc/esd install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README TODO NEWS TIPS
+ dodoc docs/esound.ps
+
+ dohtml docs/html/*.html
+}
+
diff --git a/media-sound/esound/files/digest-esound-0.2.28 b/media-sound/esound/files/digest-esound-0.2.28
new file mode 100644
index 000000000000..6fd303a81e71
--- /dev/null
+++ b/media-sound/esound/files/digest-esound-0.2.28
@@ -0,0 +1 @@
+MD5 87a9e394971457232fcd66cf9d1b0990 esound-0.2.28.tar.bz2 291942