summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/xastir/files/xastir-2.0.0-no-builtin-shapelib.diff')
-rw-r--r--media-radio/xastir/files/xastir-2.0.0-no-builtin-shapelib.diff52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-radio/xastir/files/xastir-2.0.0-no-builtin-shapelib.diff b/media-radio/xastir/files/xastir-2.0.0-no-builtin-shapelib.diff
new file mode 100644
index 000000000000..919b6aa01d64
--- /dev/null
+++ b/media-radio/xastir/files/xastir-2.0.0-no-builtin-shapelib.diff
@@ -0,0 +1,52 @@
+# Do not use builtin bundled shapelib if sci-libs/shapelib is not
+# installed. Drop shapelib support instead (bug #430704)
+--- configure.ac.orig 2012-08-27 20:17:30.000000000 +0200
++++ configure.ac 2012-08-27 20:19:32.000000000 +0200
+@@ -338,24 +338,14 @@
+
+ # Check for Shapelib
+ use_shapelib=yes
+-force_internal_shapelib=no
+ shapelib_desired=yes
+ LIBSHP=""
+ SUBSHP=""
+-AC_ARG_WITH(internal-shapelib,[ --with-internal-shapelib Force use of internal shapelib library.],force_internal_shapelib=$withval)
+ AC_ARG_WITH(shapelib,[ --without-shapelib Disable shapelib features.],shapelib_desired=$withval)
+ if test "${shapelib_desired}" = "no"; then
+ use_shapelib=no
+- force_internal_shapelib=no
+ fi
+-if test "${force_internal_shapelib}" = "yes"; then
+- AC_MSG_WARN([***************************************************************** ])
+- AC_MSG_WARN([Internal Shapelib library has been forced. ])
+- AC_MSG_WARN([***************************************************************** ])
+- # Temporary setting to get into if block below
+- use_shapelib=no
+-fi
+-if test "${shapelib_desired}" = "yes" -a "${force_internal_shapelib}" = "no"; then
++if test "${shapelib_desired}" = "yes" ; then
+ use_shapelib=no
+ AC_CHECK_HEADERS(shapefil.h libshp/shapefil.h, [AC_CHECK_LIB(shp, DBFOpen, use_shapelib=yes
+ LIBS="$LIBS -lshp"
+@@ -364,21 +354,6 @@
+ AC_DEFINE(HAVE_LIBSHP, , Define to 1 if you have the `shp' library (-lshp). )
+ break)])
+ fi
+-if test "${shapelib_desired}" = "yes" -a "${use_shapelib}" = "no"; then
+- AC_MSG_WARN([**************************************************************** ])
+- AC_MSG_WARN([Your system does not have shapelib installed. Using an internal ])
+- AC_MSG_WARN([version. This may lead to a larger filesize for the executable. ])
+- AC_MSG_WARN([Install shapelib on your system to eliminate this warning. ])
+- AC_MSG_WARN([**************************************************************** ])
+- LIBSHP="-Lshapelib -lshape"
+- CPPFLAGS="-I\$(top_srcdir)/src/shapelib $CPPFLAGS"
+- SUBSHP="shapelib"
+- use_shapelib=yes
+- force_internal_shapelib=yes
+- AC_DEFINE(HAVE_DBFGETFIELDINDEX, , Define to 1 if your `shp' library has DBFGetFieldIndex. )
+- AC_DEFINE(HAVE_LIBSHP, , Define to 1 if you have the `shp' library (-lshp). )
+- AC_DEFINE(HAVE_SHAPEFIL_H, , Define to 1 if you have the `shapefil.h' header. )
+-fi
+ AC_SUBST(SUBSHP)
+ AC_SUBST(LIBSHP)
+