summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/speex/speex-1.1.5.ebuild')
-rw-r--r--media-libs/speex/speex-1.1.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/speex/speex-1.1.5.ebuild b/media-libs/speex/speex-1.1.5.ebuild
new file mode 100644
index 000000000000..516ec3255d20
--- /dev/null
+++ b/media-libs/speex/speex-1.1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/speex/speex-1.1.5.ebuild,v 1.12 2006/04/19 13:11:09 chutzpah Exp $
+
+IUSE="ogg sse"
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Speex - Speech encoding library"
+HOMEPAGE="http://www.speex.org"
+SRC_URI="http://www.speex.org/download/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD as-is"
+KEYWORDS="~x86 ~hppa ~amd64 ~alpha ~ia64 ~ppc ~sparc ppc64"
+
+DEPEND="ogg? ( >=media-libs/libogg-1.0 )"
+
+src_compile() {
+ local myconf
+ use ogg && myconf="--enable-ogg=yes --with-ogg-dir=/usr" \
+ || myconf="--enable-ogg=no"
+ if [ "${ARCH}" != "amd64" ]
+ then
+ use sse && myconf="${myconf} --enable-sse"
+ fi
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ einstall || die
+ rm -rf ${D}/usr/share/doc/*
+
+ insinto /usr/share/doc/${P}
+ doins ${S}/doc/manual.pdf
+ dodoc AUTHORS ChangeLog README TODO NEWS
+}
+