summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/amrwb/amrwb-7.0.0.2.ebuild')
-rw-r--r--media-libs/amrwb/amrwb-7.0.0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/amrwb/amrwb-7.0.0.2.ebuild b/media-libs/amrwb/amrwb-7.0.0.2.ebuild
new file mode 100644
index 000000000000..87c0c63ff4ef
--- /dev/null
+++ b/media-libs/amrwb/amrwb-7.0.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/amrwb/amrwb-7.0.0.2.ebuild,v 1.1 2007/09/07 14:05:01 drac Exp $
+
+SPEC_VER="26204-700"
+
+DESCRIPTION="Wrapper library for 3GPP Adaptive Multi-Rate Wideband Floating-point Speech Codec"
+HOMEPAGE="http://www.penguin.cz/~utx/amr"
+SRC_URI="http://ftp.penguin.cz/pub/users/utx/amr/${P}.tar.bz2
+ http://www.3gpp.org/ftp/Specs/archive/26_series/26.204/${SPEC_VER}.zip"
+
+RESTRICT="mirror"
+
+LICENSE="LGPL-2 as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd "${S}"
+ cp "${DISTDIR}"/${SPEC_VER}.zip .
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}