summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/lprof/Manifest8
-rw-r--r--media-gfx/lprof/files/digest-lprof-1.091
-rw-r--r--media-gfx/lprof/files/lprof-1.09_fix-include.patch11
-rw-r--r--media-gfx/lprof/files/lprof-1.09_mrr_patch4.patch288
-rw-r--r--media-gfx/lprof/lprof-1.09.ebuild31
-rw-r--r--media-gfx/lprof/metadata.xml5
6 files changed, 341 insertions, 3 deletions
diff --git a/media-gfx/lprof/Manifest b/media-gfx/lprof/Manifest
index 93243eee7471..a6910bca31ed 100644
--- a/media-gfx/lprof/Manifest
+++ b/media-gfx/lprof/Manifest
@@ -1,4 +1,6 @@
-MD5 455f896034766e72a2d7cf44a3bd744d lprof-1.09.ebuild 772
-MD5 ccd27f9677836e20d828c165ad6d12b4 files/lprof-1.0.9_mrr_patch4.patch 12493
-MD5 c68c921dfc549a38258045190fedf541 files/lprof-1.0.9_fix-include.patch 290
+MD5 2acebe128bdefcb21ccb70e7abb73205 lprof-1.09.ebuild 868
+MD5 cc4254bde2f2ddb9487dc62c36a2027c ChangeLog 447
+MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
+MD5 c68c921dfc549a38258045190fedf541 files/lprof-1.09_fix-include.patch 290
+MD5 ccd27f9677836e20d828c165ad6d12b4 files/lprof-1.09_mrr_patch4.patch 12493
MD5 d761545bacdfb7a9e189c7c1186ecac6 files/digest-lprof-1.09 63
diff --git a/media-gfx/lprof/files/digest-lprof-1.09 b/media-gfx/lprof/files/digest-lprof-1.09
new file mode 100644
index 000000000000..c0eb2f6c8531
--- /dev/null
+++ b/media-gfx/lprof/files/digest-lprof-1.09
@@ -0,0 +1 @@
+MD5 731d934d2e8b6dda2e453e4b1d2be8f4 lprof-1.09.tar.gz 2538668
diff --git a/media-gfx/lprof/files/lprof-1.09_fix-include.patch b/media-gfx/lprof/files/lprof-1.09_fix-include.patch
new file mode 100644
index 000000000000..318131023ae2
--- /dev/null
+++ b/media-gfx/lprof/files/lprof-1.09_fix-include.patch
@@ -0,0 +1,11 @@
+--- lprof-1.09.orig/include/lcmsprf.h 2003-12-08 18:25:03.000000000 -0500
++++ lprof-1.09/include/lcmsprf.h 2003-12-08 18:34:26.000000000 -0500
+@@ -36,7 +36,7 @@
+
+ #ifndef __cmsprf_H
+
+-#include "lcms.h"
++#include "lcms/lcms.h"
+ #include <ctype.h>
+ #include <limits.h>
+ #include <stdarg.h>
diff --git a/media-gfx/lprof/files/lprof-1.09_mrr_patch4.patch b/media-gfx/lprof/files/lprof-1.09_mrr_patch4.patch
new file mode 100644
index 000000000000..be0d131f7406
--- /dev/null
+++ b/media-gfx/lprof/files/lprof-1.09_mrr_patch4.patch
@@ -0,0 +1,288 @@
+diff -urN lprof-1.09.orig/ICCtoIT8/Makefile lprof-1.09/ICCtoIT8/Makefile
+--- lprof-1.09.orig/ICCtoIT8/Makefile 2003-12-08 18:25:03.000000000 -0500
++++ lprof-1.09/ICCtoIT8/Makefile 2003-12-08 18:27:21.000000000 -0500
+@@ -1,6 +1,6 @@
+ SHELL = /bin/sh
+
+-CFLAGS = -g -O4 -fomit-frame-pointer -Wall -I../include -I/usr/include -I/usr/local/include
++CFLAGS = -g -O4 -fomit-frame-pointer -Wall -I../include -I../../lcms-1.09/include -I/usr/include -I/usr/local/include
+ BASEDIR = $(DESTDIR)/usr
+ BINDIR = ..
+
+diff -urN lprof-1.09.orig/Makefile lprof-1.09/Makefile
+--- lprof-1.09.orig/Makefile 2003-12-08 18:25:03.000000000 -0500
++++ lprof-1.09/Makefile 2003-12-08 18:27:21.000000000 -0500
+@@ -1,17 +1,17 @@
+ SHELL = /bin/sh
+
+ init: FORCE
+- @$(MAKE) -s all
++ @$(MAKE) all
+
+ all install clean test::
+ @echo "little cms profiler construction set 1.09 being made $@."
+ @echo "please wait ..."
+- cd src ; $(MAKE) $@ ; cd ..
+- cd ICCtoIT8 ; $(MAKE) $@ ; cd ..
+- cd qt/qtMeasurementTool; $(MAKE) $@ ; cd ../..
+- cd qt/qtMonitorProfiler; $(MAKE) $@ ; cd ../..
+- cd qt/qtScannerProfiler; $(MAKE) $@ ; cd ../..
+- cd qt/qtProfileChecker; $(MAKE) $@ ; cd ../..
++ ( cd src ; $(MAKE) )
++ ( cd ICCtoIT8 ; $(MAKE) )
++ ( cd qt/qtMeasurementTool; $(MAKE) $@ )
++ ( cd qt/qtMonitorProfiler; $(MAKE) $@ )
++ ( cd qt/qtScannerProfiler; $(MAKE) $@ )
++ ( cd qt/qtProfileChecker; $(MAKE) $@ )
+
+ FORCE:
+
+diff -urN lprof-1.09.orig/qt/qtMeasurementTool/makefile lprof-1.09/qt/qtMeasurementTool/makefile
+--- lprof-1.09.orig/qt/qtMeasurementTool/makefile 2003-12-08 18:25:03.000000000 -0500
++++ lprof-1.09/qt/qtMeasurementTool/makefile 2003-12-08 18:27:21.000000000 -0500
+@@ -17,8 +17,8 @@
+ endif
+
+ # some settings
+-INCLUDES = -I../../include -I$(QTDIR)/include -I. -I.. -I$(QTDIR)/include/qt $(KDEINCLUDE)
+-LIBS = -L$(QTDIR)/lib -L../../src $(KDELIBDIR)
++INCLUDES = -I../../include -I../../../lcms-1.09/include -I$(QTDIR)/include -I. -I.. -I$(QTDIR)/include/qt $(KDEINCLUDE)
++LIBS = -L$(QTDIR)/lib -L../../src $(KDELIBDIR) -L../../../lcms-1.09/src
+ CFLAGS = -O4 -Wall $(KDEFLAGS)
+ POSTLIB = $(KDEPOSTLIB) -lqt -llprof -llcms -lm
+
+diff -urN lprof-1.09.orig/qt/qtMeasurementTool/qtmeasurementtooldialog.cpp lprof-1.09/qt/qtMeasurementTool/qtmeasurementtooldialog.cpp
+--- lprof-1.09.orig/qt/qtMeasurementTool/qtmeasurementtooldialog.cpp 2003-12-08 18:25:03.000000000 -0500
++++ lprof-1.09/qt/qtMeasurementTool/qtmeasurementtooldialog.cpp 2003-12-08 18:27:21.000000000 -0500
+@@ -39,6 +39,7 @@
+ #include "qtlcmswidgets.h"
+ #include "qtmeasurementtooldialog.h"
+
++
+ #ifdef USE_KDE
+ #include <kfiledialog.h>
+ #endif
+@@ -402,6 +403,7 @@
+ {
+ QCanvasView::resizeEvent( e );
+ canvas()->resize(width()-4,height()-4);
++ MeasurementDialog.Reload();
+ }
+
+ void FigureEditor::contentsMousePressEvent(QMouseEvent* e)
+@@ -429,14 +431,16 @@
+
+ }
+ else
++#if 0
+ if (e -> button() & Qt::RightButton) {
+-
++#else
++ if (e -> state() & Qt::ShiftButton) {
++#endif
+ sizing = (GridItem*) *it;
+ contentsMouseMoveEvent(e);
+ }
+ else
+ if (e -> button() & Qt::LeftButton) {
+-
+ moving = (GridItem*) *it;
+ moving_start = e->pos();
+ }
+@@ -450,6 +454,7 @@
+
+ void FigureEditor::contentsMouseMoveEvent(QMouseEvent* e)
+ {
++
+ if ( moving ) {
+
+ moving->moveBy(e->pos().x() - moving_start.x(),
+@@ -529,7 +534,7 @@
+
+ Canvas = new QCanvas(w-4, h-4);
+ Canvas -> setAdvancePeriod(30);
+- FigEditor = new FigureEditor(*Canvas, CanvasFrame);
++ FigEditor = new FigureEditor(*this, *Canvas, CanvasFrame);
+ FigEditor -> clear();
+ // FigEditor-> resize(w, h);
+ CanvasFrameLayout->addWidget(FigEditor);
+@@ -839,6 +844,14 @@
+
+ }
+
++void qtMeasurementToolDialog::Reload()
++{
++ TheImage -> Reload(fn, MonitorProfileSelector ->getFilename(),
++ InputProfileSelector->getFilename(),
++ Canvas);
++}
++
++
+
+ // ------------------------------------------------------------------------------ Slots
+
+@@ -910,7 +923,7 @@
+
+ } else
+ {
+- Status->setText("Click & drag mouse to place the grid: Left - Move, Right - Size, Ctrl - UnShear. PICK when finished.");
++ Status->setText("Click & drag mouse to place the grid: Left - Move, Shift - Size, Ctrl - UnShear. PICK when finished.");
+ PickBtn->show();
+ ProofToggle -> show();
+ }
+diff -urN lprof-1.09.orig/qt/qtMeasurementTool/qtmeasurementtooldialog.h lprof-1.09/qt/qtMeasurementTool/qtmeasurementtooldialog.h
+--- lprof-1.09.orig/qt/qtMeasurementTool/qtmeasurementtooldialog.h 2003-12-08 18:25:03.000000000 -0500
++++ lprof-1.09/qt/qtMeasurementTool/qtmeasurementtooldialog.h 2003-12-08 18:27:21.000000000 -0500
+@@ -148,6 +148,7 @@
+ };
+
+
++class qtMeasurementToolDialog;
+
+ // This class implements a visual dragger for pick templates
+
+@@ -157,7 +158,7 @@
+
+ public:
+
+- FigureEditor(QCanvas& c, QWidget* parent=0, const char* name=0, WFlags f=0) : QCanvasView(&c,parent,name,f) {}
++ FigureEditor(qtMeasurementToolDialog &measurement_dialog, QCanvas& c, QWidget* parent=0, const char* name=0, WFlags f=0) : QCanvasView(&c,parent,name,f), MeasurementDialog(measurement_dialog) {}
+ void clear();
+ void resizeEvent( QResizeEvent* e );
+ protected:
+@@ -174,7 +175,7 @@
+ GridItem* sizing;
+ GridItem* unshearing;
+ QPoint moving_start;
+-
++ qtMeasurementToolDialog &MeasurementDialog;
+ };
+
+
+@@ -201,8 +202,7 @@
+
+ BOOL LoadConfig();
+ void SaveConfig();
+-
+-
++ void Reload();
+
+ public slots:
+
+diff -urN lprof-1.09.orig/qt/qtMeasurementTool/qtmeasurementtooldialogbase.ui lprof-1.09/qt/qtMeasurementTool/qtmeasurementtooldialogbase.ui
+--- lprof-1.09.orig/qt/qtMeasurementTool/qtmeasurementtooldialogbase.ui 2003-12-08 18:25:03.000000000 -0500
++++ lprof-1.09/qt/qtMeasurementTool/qtmeasurementtooldialogbase.ui 2003-12-08 18:27:21.000000000 -0500
+@@ -1674,7 +1674,7 @@
+ </property>
+ <property>
+ <name>FileMask</name>
+- <string>*.itx</string>
++ <string>*.itx;*.ITX</string>
+ </property>
+ <property>
+ <name>Prompt</name>
+@@ -1861,7 +1861,7 @@
+ </property>
+ <property>
+ <name>FileMask</name>
+- <string>*.icc; *.icm</string>
++ <string>*.icc; *.icm; *.ICC; *.ICM</string>
+ </property>
+ <property>
+ <name>Prompt</name>
+@@ -1925,7 +1925,7 @@
+ </property>
+ <property>
+ <name>FileMask</name>
+- <string>*.icc;*.icm</string>
++ <string>*.icc;*.icm;*.ICC;*.ICM</string>
+ </property>
+ <property>
+ <name>Prompt</name>
+diff -urN lprof-1.09.orig/qt/qtMonitorProfiler/Makefile lprof-1.09/qt/qtMonitorProfiler/Makefile
+--- lprof-1.09.orig/qt/qtMonitorProfiler/Makefile 2003-12-08 18:25:03.000000000 -0500
++++ lprof-1.09/qt/qtMonitorProfiler/Makefile 2003-12-08 18:27:21.000000000 -0500
+@@ -18,8 +18,8 @@
+
+
+ # some settings
+-INCLUDES = -I../../include -I$(QTDIR)/include -I. -I.. -I$(QTDIR)/include/qt $(KDEINCLUDE)
+-LIBS = -L$(QTDIR)/lib -L../../src $(KDELIBDIR)
++INCLUDES = -I../../include -I../../../lcms-1.09/include -I$(QTDIR)/include -I. -I.. -I$(QTDIR)/include/qt $(KDEINCLUDE)
++LIBS = -L$(QTDIR)/lib -L../../src $(KDELIBDIR) -L../../../lcms-1.09/src
+ CFLAGS = -O4 -Wall $(KDEFLAGS)
+ POSTLIB = $(KDEPOSTLIB) -lqt -llprof -llcms -lm
+ BINDIR = ../../
+diff -urN lprof-1.09.orig/qt/qtMonitorProfiler/qtmonitorprofilerdialogbase.ui lprof-1.09/qt/qtMonitorProfiler/qtmonitorprofilerdialogbase.ui
+--- lprof-1.09.orig/qt/qtMonitorProfiler/qtmonitorprofilerdialogbase.ui 2003-12-08 18:25:03.000000000 -0500
++++ lprof-1.09/qt/qtMonitorProfiler/qtmonitorprofilerdialogbase.ui 2003-12-08 18:27:21.000000000 -0500
+@@ -1261,7 +1261,7 @@
+ </property>
+ <property>
+ <name>FileMask</name>
+- <string>IT8/CGATS.5 files (*.it? *.cgs);;All files (*.*)</string>
++ <string>IT8/CGATS.5 files (*.it? *.cgs *.IT? *.CGS);;All files (*.*)</string>
+ </property>
+ <property>
+ <name>Prompt</name>
+@@ -1353,7 +1353,7 @@
+ </property>
+ <property>
+ <name>FileMask</name>
+- <string>icc profiles (*.icc *.icm);;All files (*.*)</string>
++ <string>icc profiles (*.icc *.icm *.ICC *.ICM);;All files (*.*)</string>
+ </property>
+ <property>
+ <name>Prompt</name>
+diff -urN lprof-1.09.orig/qt/qtProfileChecker/makefile lprof-1.09/qt/qtProfileChecker/makefile
+--- lprof-1.09.orig/qt/qtProfileChecker/makefile 2003-12-08 18:25:03.000000000 -0500
++++ lprof-1.09/qt/qtProfileChecker/makefile 2003-12-08 18:27:21.000000000 -0500
+@@ -18,8 +18,9 @@
+
+
+ # some settings
+-INCLUDES = -I../../include -I$(QTDIR)/include -I. -I.. -I$(QTDIR)/include/qt $(KDEINCLUDE)
+-LIBS = -L$(QTDIR)/lib -L../../src $(KDELIBDIR)
++INCLUDES = -I../../include -I../../../lcms-1.09/include -I$(QTDIR)/include -I. -I.. -I$(QTDIR)/include/qt $(KDEINCLUDE)
++LIBS = -L$(QTDIR)/lib -L../../src $(KDELIBDIR) -L../../../lcms-1.09/src
++
+ CFLAGS = -O4 -Wall $(KDEFLAGS)
+ POSTLIB = $(KDEPOSTLIB) -lqt -llprof -llcms -lm
+ BINDIR = ../../
+diff -urN lprof-1.09.orig/qt/qtProfileChecker/qtprofilecheckerdialogbase.ui lprof-1.09/qt/qtProfileChecker/qtprofilecheckerdialogbase.ui
+--- lprof-1.09.orig/qt/qtProfileChecker/qtprofilecheckerdialogbase.ui 2003-12-08 18:25:03.000000000 -0500
++++ lprof-1.09/qt/qtProfileChecker/qtprofilecheckerdialogbase.ui 2003-12-08 18:27:21.000000000 -0500
+@@ -1432,7 +1432,7 @@
+ </property>
+ <property>
+ <name>FileMask</name>
+- <string>*.icm;*.icc;*.pf</string>
++ <string>*.icm;*.icc;*.pf;*.ICM;*.ICC;*.PF</string>
+ </property>
+ <property>
+ <name>Prompt</name>
+diff -urN lprof-1.09.orig/qt/qtScannerProfiler/Makefile lprof-1.09/qt/qtScannerProfiler/Makefile
+--- lprof-1.09.orig/qt/qtScannerProfiler/Makefile 2003-12-08 18:25:03.000000000 -0500
++++ lprof-1.09/qt/qtScannerProfiler/Makefile 2003-12-08 18:27:21.000000000 -0500
+@@ -18,8 +18,8 @@
+
+
+ # some settings
+-INCLUDES = -I../../include -I$(QTDIR)/include -I. -I.. -I$(QTDIR)/include/qt $(KDEINCLUDE)
+-LIBS = -L$(QTDIR)/lib -L../../src $(KDELIBDIR)
++INCLUDES = -I../../include -I../../../lcms-1.09/include -I$(QTDIR)/include -I. -I.. -I$(QTDIR)/include/qt $(KDEINCLUDE)
++LIBS = -L$(QTDIR)/lib -L../../src $(KDELIBDIR) -L../../../lcms-1.09/src
+ CFLAGS = -O4 -Wall $(KDEFLAGS)
+ POSTLIB = $(KDEPOSTLIB) -lqt -llprof -llcms -lm
+ BINDIR = ../../
+diff -urN lprof-1.09.orig/src/makefile lprof-1.09/src/makefile
+--- lprof-1.09.orig/src/makefile 2003-12-08 18:25:03.000000000 -0500
++++ lprof-1.09/src/makefile 2003-12-08 18:27:21.000000000 -0500
+@@ -1,6 +1,6 @@
+ SHELL = /bin/sh
+
+-CFLAGS = -g -O4 -I../include -fomit-frame-pointer -Wall
++CFLAGS = -g -O4 -I../include -I../../lcms-1.09/include -fomit-frame-pointer -Wall
+ BASEDIR = $(DESTDIR)/usr
+ BINDIR = $(BASEDIR)/bin
+ LIBDIR = $(BASEDIR)/lib
diff --git a/media-gfx/lprof/lprof-1.09.ebuild b/media-gfx/lprof/lprof-1.09.ebuild
new file mode 100644
index 000000000000..4d11716a6ff0
--- /dev/null
+++ b/media-gfx/lprof/lprof-1.09.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/lprof/lprof-1.09.ebuild,v 1.1 2003/12/09 16:50:12 lanius Exp $
+
+DESCRIPTION="Little CMS ICC profile construction set"
+HOMEPAGE="http://www.littlecms.com/profilers.htm"
+SRC_URI="http://www.littlecms.com/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="x11-libs/qt
+ >=media-libs/lcms-1.09"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}_mrr_patch4.patch
+ epatch ${FILESDIR}/${P}_fix-include.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dodoc README COPYING manual.txt
+ exeinto /usr/bin
+ doexe {icc2it8,qtmeasurementtool,qtmonitorprofiler,qtprofilechecker,qtscannerprofiler}
+ dodir /usr/share/lprof
+ cp -ar ${S}/{pics,profiles,targets,template} ${D}/usr/share/lprof
+}
diff --git a/media-gfx/lprof/metadata.xml b/media-gfx/lprof/metadata.xml
new file mode 100644
index 000000000000..1fa0ca569505
--- /dev/null
+++ b/media-gfx/lprof/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>printing</herd>
+</pkgmetadata>