summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-mta/qmail-ldap/files')
-rw-r--r--mail-mta/qmail-ldap/files/errno.patch38
-rw-r--r--mail-mta/qmail-ldap/files/errno.patch.bz2bin401 -> 0 bytes
-rw-r--r--mail-mta/qmail-ldap/files/homedir.patch24
-rw-r--r--mail-mta/qmail-ldap/files/homedir.patch.bz2bin527 -> 0 bytes
-rw-r--r--mail-mta/qmail-ldap/files/qmail-linksync.patch54
-rw-r--r--mail-mta/qmail-ldap/files/qmail-linksync.patch.bz2bin687 -> 0 bytes
-rw-r--r--mail-mta/qmail-ldap/files/qmail-queue.patch49
-rw-r--r--mail-mta/qmail-ldap/files/qmail-queue.patch.bz2bin722 -> 0 bytes
-rw-r--r--mail-mta/qmail-ldap/files/tls.patch20
-rw-r--r--mail-mta/qmail-ldap/files/tls.patch.bz2bin406 -> 0 bytes
10 files changed, 185 insertions, 0 deletions
diff --git a/mail-mta/qmail-ldap/files/errno.patch b/mail-mta/qmail-ldap/files/errno.patch
new file mode 100644
index 000000000000..f9b77b91e065
--- /dev/null
+++ b/mail-mta/qmail-ldap/files/errno.patch
@@ -0,0 +1,38 @@
+% diff -u3 error.h.orig error.h
+--- error.h.orig 1998-06-15 06:53:16.000000000 -0400
++++ error.h 2002-12-24 20:28:40.000000000 -0500
+@@ -1,7 +1,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;
+
+
+% diff -u3 dns.c.orig dns.c
+--- dns.c.orig 2002-08-09 19:20:48.000000000 -0400
++++ dns.c 2002-12-24 20:42:46.000000000 -0500
+@@ -7,8 +7,6 @@
+ #include <errno.h>
+ extern int res_query();
+ extern int res_search();
+-extern int errno;
+-extern int h_errno;
+ #include "ip.h"
+ #include "ipalloc.h"
+ #include "fmt.h"
+
+
+% diff -u3 cdb_seek.c.orig cdb_seek.c
+--- cdb_seek.c.orig 1998-06-15 06:53:16.000000000 -0400
++++ cdb_seek.c 2002-12-24 20:42:52.000000000 -0500
+@@ -1,6 +1,5 @@
+ #include <sys/types.h>
+ #include <errno.h>
+-extern int errno;
+ #include "cdb.h"
+
+ #ifndef SEEK_SET
diff --git a/mail-mta/qmail-ldap/files/errno.patch.bz2 b/mail-mta/qmail-ldap/files/errno.patch.bz2
deleted file mode 100644
index 5b21c6060d85..000000000000
--- a/mail-mta/qmail-ldap/files/errno.patch.bz2
+++ /dev/null
Binary files differ
diff --git a/mail-mta/qmail-ldap/files/homedir.patch b/mail-mta/qmail-ldap/files/homedir.patch
new file mode 100644
index 000000000000..32c08542a3f6
--- /dev/null
+++ b/mail-mta/qmail-ldap/files/homedir.patch
@@ -0,0 +1,24 @@
+--- Makefile.orig 2003-07-19 19:19:24.000000000 -0700
++++ Makefile 2003-07-19 19:21:20.000000000 -0700
+@@ -10,7 +10,7 @@
+ # systems)
+ # -DEXTERNAL_TODO to use the external high-performance todo processing (this
+ # avoids the silly qmail syndrome with high injection rates)
+-#LDAPFLAGS=-DQLDAP_CLUSTER -DEXTERNAL_TODO
++LDAPFLAGS=-DQLDAP_CLUSTER
+ #LDAPFLAGS=-DQLDAP_CLUSTER -DEXTERNAL_TODO -DDASH_EXT
+
+ # Perhaps you have different ldap libraries, change them here
+@@ -41,10 +41,10 @@
+ MNW=-DMAKE_NETSCAPE_WORK
+
+ # to enable the auto-maildir-make feature uncomment the next line
+-#MDIRMAKE=-DAUTOMAILDIRMAKE
++MDIRMAKE=-DAUTOMAILDIRMAKE
+
+ # to enable the auto-homedir-make feature uncomment the next line
+-#HDIRMAKE=-DAUTOHOMEDIRMAKE
++HDIRMAKE=-DAUTOHOMEDIRMAKE
+
+ # on most systems we need this to make checkpassword
+ SHADOWLIBS=-lcrypt
diff --git a/mail-mta/qmail-ldap/files/homedir.patch.bz2 b/mail-mta/qmail-ldap/files/homedir.patch.bz2
deleted file mode 100644
index a3bc67e6fd92..000000000000
--- a/mail-mta/qmail-ldap/files/homedir.patch.bz2
+++ /dev/null
Binary files differ
diff --git a/mail-mta/qmail-ldap/files/qmail-linksync.patch b/mail-mta/qmail-ldap/files/qmail-linksync.patch
new file mode 100644
index 000000000000..1b35f12aaa1f
--- /dev/null
+++ b/mail-mta/qmail-ldap/files/qmail-linksync.patch
@@ -0,0 +1,54 @@
+--- ../qmail-1.03.orig/qmail-local.c Mon Jun 15 12:53:16 1998
++++ qmail-local.c Sun Jul 16 16:19:04 2000
+@@ -1,5 +1,6 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <fcntl.h>
+ #include "readwrite.h"
+ #include "sig.h"
+ #include "env.h"
+@@ -128,6 +129,9 @@
+ if (close(fd) == -1) goto fail; /* NFS dorks */
+
+ if (link(fntmptph,fnnewtph) == -1) goto fail;
++ if ((fd = open(fnnewtph, O_RDONLY)) < 0 ||
++ fsync(fd) < 0 || close(fd) < 0) goto fail;
++
+ /* if it was error_exist, almost certainly successful; i hate NFS */
+ tryunlinktmp(); _exit(0);
+
+--- ../qmail-1.03.orig/qmail-queue.c Mon Jun 15 12:53:16 1998
++++ qmail-queue.c Sun Jul 16 16:19:33 2000
+@@ -1,5 +1,6 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <fcntl.h>
+ #include "readwrite.h"
+ #include "sig.h"
+ #include "exit.h"
+@@ -155,6 +156,7 @@
+ {
+ unsigned int len;
+ char ch;
++ int fd;
+
+ sig_blocknone();
+ umask(033);
+@@ -183,7 +185,7 @@
+ todofn = fnnum("todo/",0);
+ intdfn = fnnum("intd/",0);
+
+- if (link(pidfn,messfn) == -1) die(64);
++ if (link(pidfn,messfn) == -1) die(64);
+ if (unlink(pidfn) == -1) die(63);
+ flagmademess = 1;
+
+@@ -248,6 +250,8 @@
+ if (fsync(intdfd) == -1) die_write();
+
+ if (link(intdfn,todofn) == -1) die(66);
++ if ((fd = open(todofn, O_RDONLY)) < 0 ||
++ fsync(fd) < 0 || close(fd) < 0) die(66);
+
+ triggerpull();
+ die(0);
diff --git a/mail-mta/qmail-ldap/files/qmail-linksync.patch.bz2 b/mail-mta/qmail-ldap/files/qmail-linksync.patch.bz2
deleted file mode 100644
index e758ba32fced..000000000000
--- a/mail-mta/qmail-ldap/files/qmail-linksync.patch.bz2
+++ /dev/null
Binary files differ
diff --git a/mail-mta/qmail-ldap/files/qmail-queue.patch b/mail-mta/qmail-ldap/files/qmail-queue.patch
new file mode 100644
index 000000000000..4edd5fad86e5
--- /dev/null
+++ b/mail-mta/qmail-ldap/files/qmail-queue.patch
@@ -0,0 +1,49 @@
+diff -u qmail-1.03-orig/Makefile qmail-1.03/Makefile
+--- qmail-1.03-orig/Makefile Mon Jun 15 04:53:16 1998
++++ Makefile Tue Jan 19 10:52:24 1999
+@@ -1483,12 +1483,12 @@
+ trigger.o fmtqfn.o quote.o now.o readsubdir.o qmail.o date822fmt.o \
+ datetime.a case.a ndelay.a getln.a wait.a seek.a fd.a sig.a open.a \
+ lock.a stralloc.a alloc.a substdio.a error.a str.a fs.a auto_qmail.o \
+-auto_split.o
++auto_split.o env.a
+ ./load qmail-send qsutil.o control.o constmap.o newfield.o \
+ prioq.o trigger.o fmtqfn.o quote.o now.o readsubdir.o \
+ qmail.o date822fmt.o datetime.a case.a ndelay.a getln.a \
+ wait.a seek.a fd.a sig.a open.a lock.a stralloc.a alloc.a \
+- substdio.a error.a str.a fs.a auto_qmail.o auto_split.o
++ substdio.a error.a str.a fs.a auto_qmail.o auto_split.o env.a
+
+ qmail-send.0: \
+ qmail-send.8
+diff -u qmail-1.03-orig/qmail.c qmail-1.03/qmail.c
+--- qmail-1.03-orig/qmail.c Mon Jun 15 04:53:16 1998
++++ qmail.c Tue Jan 19 09:57:36 1999
+@@ -6,14 +6,25 @@
+ #include "fd.h"
+ #include "qmail.h"
+ #include "auto_qmail.h"
++#include "env.h"
+
+-static char *binqqargs[2] = { "bin/qmail-queue", 0 } ;
++static char *binqqargs[2] = { 0, 0 } ;
++
++static void setup_qqargs()
++{
++ if(!binqqargs[0])
++ binqqargs[0] = env_get("QMAILQUEUE");
++ if(!binqqargs[0])
++ binqqargs[0] = "bin/qmail-queue";
++}
+
+ int qmail_open(qq)
+ struct qmail *qq;
+ {
+ int pim[2];
+ int pie[2];
++
++ setup_qqargs();
+
+ if (pipe(pim) == -1) return -1;
+ if (pipe(pie) == -1) { close(pim[0]); close(pim[1]); return -1; }
+
diff --git a/mail-mta/qmail-ldap/files/qmail-queue.patch.bz2 b/mail-mta/qmail-ldap/files/qmail-queue.patch.bz2
deleted file mode 100644
index 9f839f8209bf..000000000000
--- a/mail-mta/qmail-ldap/files/qmail-queue.patch.bz2
+++ /dev/null
Binary files differ
diff --git a/mail-mta/qmail-ldap/files/tls.patch b/mail-mta/qmail-ldap/files/tls.patch
new file mode 100644
index 000000000000..c7cb30377976
--- /dev/null
+++ b/mail-mta/qmail-ldap/files/tls.patch
@@ -0,0 +1,20 @@
+--- Makefile.orig 2003-07-19 19:40:10.000000000 -0700
++++ Makefile 2003-07-19 19:41:12.000000000 -0700
+@@ -27,13 +27,13 @@
+ # TLS (SMTP encryption) in qmail-smtpd and qmail-remote, see TLS.readme
+ # You need OpenSSL for this
+ # TLS enable
+-#TLSON=-DTLS
++TLSON=-DTLS
+ # Path to OpenSSL includes
+-#TLSINCLUDES=-I/usr/local/include
++TLSINCLUDES=-I/usr/include
+ # Path to OpenSSL libraries
+-#TLSLIBS=-L/usr/local/lib -lssl -lcrypto
++TLSLIBS=-L/usr/lib -lssl -lcrypto
+ # Path to OpenSSL binary
+-#OPENSSLBIN=/usr/local/bin/openssl
++OPENSSLBIN=/usr/bin/openssl
+ #OPENSSLBIN=openssl
+
+ # to make the Netscape download progress bar work with qmail-pop3d
diff --git a/mail-mta/qmail-ldap/files/tls.patch.bz2 b/mail-mta/qmail-ldap/files/tls.patch.bz2
deleted file mode 100644
index 7534c54789d9..000000000000
--- a/mail-mta/qmail-ldap/files/tls.patch.bz2
+++ /dev/null
Binary files differ