summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/superkaramba/superkaramba-4.7.0.ebuild')
-rw-r--r--kde-base/superkaramba/superkaramba-4.7.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/superkaramba/superkaramba-4.7.0.ebuild b/kde-base/superkaramba/superkaramba-4.7.0.ebuild
new file mode 100644
index 000000000000..b14acdf02246
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.7.0.ebuild,v 1.1 2011/07/27 14:04:38 alexxy Exp $
+
+EAPI=3
+
+KMNAME="kdeutils"
+PYTHON_DEPEND="python? 2"
+inherit python kde4-meta
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+DEPEND="
+ media-libs/qimageblitz
+ python? ( $(add_kdebase_dep pykde4) )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython) )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-as-needed.patch" )
+
+pkg_setup() {
+ kde4-meta_pkg_setup
+ python_set_active_version 2
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ kde4-meta_src_configure
+}