summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/solid/solid-4.5.3.ebuild')
-rw-r--r--kde-base/solid/solid-4.5.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/kde-base/solid/solid-4.5.3.ebuild b/kde-base/solid/solid-4.5.3.ebuild
new file mode 100644
index 000000000000..ae28f2c1a71c
--- /dev/null
+++ b/kde-base/solid/solid-4.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/solid-4.5.3.ebuild,v 1.1 2010/11/03 16:30:57 scarabeus Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="test"
+inherit kde4-meta
+
+DESCRIPTION="Solid: the KDE hardware library"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="bluetooth debug +hal networkmanager wicd"
+
+# solid/CMakeLists.txt has an add_subdirectory statement that depends on
+# networkmanager-0.7, referring to a non-existant directory, restricted to =0.6*
+# for now.
+DEPEND="
+ bluetooth? ( net-wireless/bluez )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ wicd? ( net-misc/wicd )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep solid-runtime)
+ hal? ( sys-apps/hal )
+"
+
+KMEXTRA="
+ libs/solid/
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.4.69-darwin-compile-powermanager.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with bluetooth BlueZ)
+ $(cmake-utils_use_with networkmanager NetworkManager)
+ $(cmake-utils_use_build wicd)
+ )
+
+ kde4-meta_src_configure
+}