summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/qyoto/qyoto-4.7.1.ebuild')
-rw-r--r--kde-base/qyoto/qyoto-4.7.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-base/qyoto/qyoto-4.7.1.ebuild b/kde-base/qyoto/qyoto-4.7.1.ebuild
new file mode 100644
index 000000000000..d9d8c4d37681
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.7.1.ebuild,v 1.1 2011/09/07 20:13:43 alexxy Exp $
+
+EAPI=4
+
+KDE_REQUIRED="never"
+KDE_SCM="git"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +phonon qscintilla webkit"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}