summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/lisa/lisa-3.5.5.ebuild')
-rw-r--r--kde-base/lisa/lisa-3.5.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-base/lisa/lisa-3.5.5.ebuild b/kde-base/lisa/lisa-3.5.5.ebuild
new file mode 100644
index 000000000000..b714af53e8be
--- /dev/null
+++ b/kde-base/lisa/lisa-3.5.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/lisa/lisa-3.5.5.ebuild,v 1.1 2006/10/03 13:06:17 flameeyes Exp $
+
+KMNAME=kdenetwork
+KMMODULE=lanbrowsing
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils flag-o-matic
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
+
+DESCRIPTION="KDE Lan Information Server - allows KDE desktops to share information over a network."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+KMEXTRA="doc/kcontrol/lanbrowser"
+
+src_compile() {
+ export BINDNOW_FLAGS="$(bindnow-flags)"
+ kde-meta_src_compile
+}
+
+src_install() {
+ kde-meta_src_install
+
+ chmod u+s ${D}/${KDEDIR}/bin/reslisa
+
+ # lisa, reslisa initscripts
+ dodir /etc/init.d
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${WORKDIR}/patches/lisa > ${D}/etc/init.d/lisa
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${WORKDIR}/patches/reslisa > ${D}/etc/init.d/reslisa
+ chmod +x ${D}/etc/init.d/*
+
+ insinto /etc/conf.d
+ newins ${WORKDIR}/patches/lisa.conf lisa
+ newins ${WORKDIR}/patches/reslisa.conf reslisa
+
+ for x in /etc/lisarc /etc/reslisarc; do
+ echo '# Default lisa/reslisa configfile' > $D/$x
+ done
+}