summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/libplasma/libplasma-4.0.2.ebuild')
-rw-r--r--kde-base/libplasma/libplasma-4.0.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/kde-base/libplasma/libplasma-4.0.2.ebuild b/kde-base/libplasma/libplasma-4.0.2.ebuild
new file mode 100644
index 000000000000..c66b658b3228
--- /dev/null
+++ b/kde-base/libplasma/libplasma-4.0.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libplasma/libplasma-4.0.2.ebuild,v 1.1 2008/03/11 00:01:31 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+KMMODULE="libs/plasma"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Plasma: KDE desktop framework"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl test xinerama"
+
+COMMONDEPEND="
+ !<kde-base/plasma-3.96.0
+ >=kde-base/libkworkspace-${PV}:${SLOT}
+ >=kde-base/libtaskmanager-${PV}:${SLOT}
+ x11-libs/libXau
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ opengl? ( virtual/opengl )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="${COMMONDEPEND}"
+
+KMEXTRACTONLY="krunner/org.freedesktop.ScreenSaver.xml
+ krunner/org.kde.krunner.Interface.xml
+ ksmserver/org.kde.KSMServerInterface.xml
+ libs/taskmanager/"
+
+KDE4_BUILT_WITH_USE_CHECK="app-misc/strigi dbus qt4"
+
+# Disabling tests for now. 3 out of 3 broken now. last tested on 4.0.1.
+RESTRICT="test"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_compile
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # Outsmart our doc-handling, to avoid a collision with plasma.
+ rm -rf "${D}"/${KDEDIR}/share/doc/
+}