summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kwin/kwin-3.5.10.ebuild')
-rw-r--r--kde-base/kwin/kwin-3.5.10.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/kde-base/kwin/kwin-3.5.10.ebuild b/kde-base/kwin/kwin-3.5.10.ebuild
new file mode 100644
index 000000000000..0a4b8cc48145
--- /dev/null
+++ b/kde-base/kwin/kwin-3.5.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-3.5.10.ebuild,v 1.1 2008/09/14 00:00:14 carlo Exp $
+
+KMNAME=kdebase
+EAPI="1"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility xcomposite"
+
+DEPEND="x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ xcomposite? ( x11-libs/libXcomposite x11-libs/libXdamage )"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-13.tar.bz2"
+
+src_compile() {
+ myconf="$myconf $(use_with xcomposite composite)"
+ kde-meta_src_compile
+}