summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/ksquares/ksquares-4.2.3.ebuild')
-rw-r--r--kde-base/ksquares/ksquares-4.2.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-base/ksquares/ksquares-4.2.3.ebuild b/kde-base/ksquares/ksquares-4.2.3.ebuild
new file mode 100644
index 000000000000..4720d347ca11
--- /dev/null
+++ b/kde-base/ksquares/ksquares-4.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksquares/ksquares-4.2.3.ebuild,v 1.1 2009/05/06 23:54:51 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdegames"
+inherit games-ggz kde4-meta
+
+DESCRIPTION="KSquares is an implementation of the game squares for KDE4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc"
+
+src_prepare() {
+ # cmake is doing this really weird
+ sed -i \
+ -e "s:register_ggz_module:#register_ggz_module:g" \
+ ${PN}/src/CMakeLists.txt || die "ggz removal failed"
+
+ kde4-meta_src_prepare
+}
+
+src_install() {
+ kde4-meta_src_install
+ # and also we have to prepare the ggz dir
+ mkdir -p "${D}"/usr/share/ggz/modules
+ cp ${PN}/src/module.dsc "${D}"/usr/share/ggz/modules/${P}.dsc
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ games-ggz_pkg_postinst
+}
+
+pkg_postrm() {
+ kde4-meta_pkg_postrm
+ games-ggz_pkg_postrm
+}