summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kpilot/kpilot-4.3.4.ebuild')
-rw-r--r--kde-base/kpilot/kpilot-4.3.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-base/kpilot/kpilot-4.3.4.ebuild b/kde-base/kpilot/kpilot-4.3.4.ebuild
new file mode 100644
index 000000000000..c3f5ba0b2d86
--- /dev/null
+++ b/kde-base/kpilot/kpilot-4.3.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/kpilot-4.3.4.ebuild,v 1.1 2009/12/01 10:57:55 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KPilot is software for syncing PalmOS based handhelds."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="avantgo crypt debug +handbook"
+
+DEPEND="
+ >=app-pda/pilot-link-0.12
+ $(add_kdebase_dep libkdepim)
+ avantgo? ( >=dev-libs/libmal-0.40 )
+ crypt? ( app-crypt/qca:2 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with avantgo Mal)
+ $(cmake-utils_use_with crypt QCA2)"
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test (as of 4.2.87)
+ sed -i -e '/keyringcategorysynctest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/"${PN}"/conduits/keyringconduit/tests/CMakeLists.txt || \
+ die "sed to disable keyringcategorysynctest failed."
+
+ kde4-meta_src_test
+}