summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kompare/kompare-4.2.3.ebuild')
-rw-r--r--kde-base/kompare/kompare-4.2.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/kde-base/kompare/kompare-4.2.3.ebuild b/kde-base/kompare/kompare-4.2.3.ebuild
new file mode 100644
index 000000000000..3ce94af63187
--- /dev/null
+++ b/kde-base/kompare/kompare-4.2.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kompare/kompare-4.2.3.ebuild,v 1.1 2009/05/06 23:42:57 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kompare is a program to view the differences between files."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc"
+
+src_prepare() {
+ # Disable hardcoded kdepimlibs check - only 4.2 branch is affected
+ sed -i -e 's/find_package(KdepimLibs REQUIRED)/macro_optional_find_package(KdepimLibs)/' \
+ CMakeLists.txt || die "failed to disable kdepimlibs hardcoded check"
+
+ kde4-meta_src_prepare
+}