summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdelibs/files')
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5-lua.patch32
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5.0-bindnow.patch33
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5.0-kicker-crash.patch38
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5.2-kssl-3des.patch15
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5.2-xorg7-rgbtxt.patch16
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5.3-konqcrash.patch13
6 files changed, 0 insertions, 147 deletions
diff --git a/kde-base/kdelibs/files/kdelibs-3.5-lua.patch b/kde-base/kdelibs/files/kdelibs-3.5-lua.patch
deleted file mode 100644
index 72e25434ce08..000000000000
--- a/kde-base/kdelibs/files/kdelibs-3.5-lua.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Index: kate/part/configure.in.in
-===================================================================
---- kate/part/configure.in.in (revision 586622)
-+++ kate/part/configure.in.in (working copy)
-@@ -4,6 +4,9 @@
-
- HAVE_LUA=""
-
-+ AC_ARG_WITH([lua],
-+ AC_HELP_STRING([--without-lua], [Build without Lua libraries (default: check)]))
-+
- AC_ARG_WITH(lua-dir,
- AC_HELP_STRING([--with-lua-dir=DIR],[where the root of Lua 5.x is installed]),
- [
-@@ -21,6 +24,9 @@
- LUA_LIBS="-L$withval" ])
-
-
-+ if test "x$with_lua" = "xno"; then
-+ AC_MSG_RESULT([Not using Lua])
-+ else
- if ! test "x$LUA" = "x"; then
- AC_MSG_RESULT(using Lua from $LUA)
- fi
-@@ -76,6 +82,7 @@
- AC_SUBST(LUA)
- AC_SUBST(LUA_INCLUDES)
- AC_SUBST(LUA_LIBS)
-+ fi
-
- ])
-
diff --git a/kde-base/kdelibs/files/kdelibs-3.5.0-bindnow.patch b/kde-base/kdelibs/files/kdelibs-3.5.0-bindnow.patch
deleted file mode 100644
index 3a7e1133a5d7..000000000000
--- a/kde-base/kdelibs/files/kdelibs-3.5.0-bindnow.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Add support for BINDNOW_FLAGS to build kgrantpty and kpac_dhcp_helper with
-non-lazy bindings, to improve security and fix installation on
-FEATURES=stricter.
-See bug #113937.
-
-Requires the ebuild to export BINDNOW_FLAGS="$(bindnow-flags)".
-
-Index: kdelibs-3.5.0/kdecore/Makefile.am
-===================================================================
---- kdelibs-3.5.0.orig/kdecore/Makefile.am
-+++ kdelibs-3.5.0/kdecore/Makefile.am
-@@ -169,7 +169,7 @@ kde_config_LDFLAGS = $(KDE_RPATH) $(KDE_
-
- kgrantpty_SOURCES = kgrantpty.c
- kgrantpty_CFLAGS= $(KDE_USE_FPIE)
--kgrantpty_LDFLAGS = $(KDE_USE_PIE) $(KDE_RPATH) $(all_libraries)
-+kgrantpty_LDFLAGS = $(KDE_USE_PIE) $(KDE_RPATH) $(all_libraries) $(BINDNOW_FLAGS)
- kgrantpty_LDADD = ./libkdefakes.la
-
- # kgrantpty needs to be installed setuid root
-Index: kdelibs-3.5.0/kio/misc/kpac/Makefile.am
-===================================================================
---- kdelibs-3.5.0.orig/kio/misc/kpac/Makefile.am
-+++ kdelibs-3.5.0/kio/misc/kpac/Makefile.am
-@@ -14,7 +14,7 @@ kded_proxyscout_la_LIBADD = $(LIB_KIO) $
-
- kpac_dhcp_helper_SOURCES = kpac_dhcp_helper.c
- kpac_dhcp_helper_CFLAGS = $(KDE_USE_FPIE)
--kpac_dhcp_helper_LDFLAGS = $(KDE_USE_PIE)
-+kpac_dhcp_helper_LDFLAGS = $(KDE_USE_PIE) $(BINDNOW_FLAGS)
- kpac_dhcp_helper_LDADD = $(LIBSOCKET)
-
- noinst_HEADERS = proxyscout.h script.h downloader.h discovery.h
diff --git a/kde-base/kdelibs/files/kdelibs-3.5.0-kicker-crash.patch b/kde-base/kdelibs/files/kdelibs-3.5.0-kicker-crash.patch
deleted file mode 100644
index 8f97cb41b979..000000000000
--- a/kde-base/kdelibs/files/kdelibs-3.5.0-kicker-crash.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Index: kio/kio/kdirlister.cpp
-===================================================================
---- kio/kio/kdirlister.cpp (revision 479279)
-+++ kio/kio/kdirlister.cpp (revision 479280)
-@@ -415,8 +415,11 @@
- url.adjustPath( -1 );
- QString urlStr = url.url();
- QPtrList<KDirLister> *holders = urlsCurrentlyHeld[urlStr];
-- Q_ASSERT( holders );
-- holders->removeRef( lister );
-+ //Q_ASSERT( holders );
-+ if ( holders )
-+ {
-+ holders->removeRef( lister );
-+ }
-
- // remove the dir from lister->d->lstDirs so that it doesn't contain things
- // that itemsInUse doesn't. When emitting the canceled signals lstDirs must
-@@ -425,9 +428,8 @@
- lister->d->lstDirs.remove( lister->d->lstDirs.find( url ) );
-
- DirItem *item = itemsInUse[urlStr];
-- Q_ASSERT( item );
-
-- if ( holders->isEmpty() )
-+ if ( holders && holders->isEmpty() )
- {
- urlsCurrentlyHeld.remove( urlStr ); // this deletes the (empty) holders list
- if ( !urlsCurrentlyListed[urlStr] )
-@@ -454,7 +456,7 @@
- if ( notify )
- emit lister->clear( url );
-
-- if ( item->complete )
-+ if ( item && item->complete )
- {
- kdDebug(7004) << k_funcinfo << lister << " item moved into cache: " << url << endl;
- itemsCached.insert( urlStr, item ); // TODO: may return false!!
diff --git a/kde-base/kdelibs/files/kdelibs-3.5.2-kssl-3des.patch b/kde-base/kdelibs/files/kdelibs-3.5.2-kssl-3des.patch
deleted file mode 100644
index 56347b685539..000000000000
--- a/kde-base/kdelibs/files/kdelibs-3.5.2-kssl-3des.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- kdelibs-3.5.2/kio/kssl/ksslsettings.cc.old 2006-04-05 23:20:42.000000000 +0930
-+++ kdelibs-3.5.2/kio/kssl/ksslsettings.cc 2006-04-05 23:21:27.000000000 +0930
-@@ -179,11 +179,10 @@
- }
-
- // Remove any ADH ciphers as per RFC2246
-- // Also remove NULL ciphers and 168bit ciphers
- for (unsigned int i = 0; i < cipherSort.count(); i++) {
- CipherNode *j = 0L;
- while ((j = cipherSort.at(i)) != 0L) {
-- if (j->name.contains("ADH-") || j->name.contains("NULL-") || j->name.contains("DES-CBC3-SHA") || j->name.contains("FZA")) {
-+ if (j->name.contains("ADH-")) {
- cipherSort.remove(j);
- } else {
- break;
diff --git a/kde-base/kdelibs/files/kdelibs-3.5.2-xorg7-rgbtxt.patch b/kde-base/kdelibs/files/kdelibs-3.5.2-xorg7-rgbtxt.patch
deleted file mode 100644
index 13b270e9f433..000000000000
--- a/kde-base/kdelibs/files/kdelibs-3.5.2-xorg7-rgbtxt.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: kdelibs-3.5.2/configure.in.in
-===================================================================
---- kdelibs-3.5.2.orig/configure.in.in
-+++ kdelibs-3.5.2/configure.in.in
-@@ -306,7 +306,10 @@ if test "x$kde_use_qt_emb" != "xyes"; th
- CXXFLAGS="$CXXFLAGS $USE_RTTI"
- fi
-
--rgb_file="$x_libraries/X11/rgb.txt"
-+AC_ARG_WITH([rgbfile],
-+ AC_HELP_STRING([--with-rgbfile=path], [Define custom path for rgb.txt. (default: \$(x11libdir)/X11/rgb.txt)]),
-+ [rgb_file=$withval], [rgb_file="$x_libraries/X11/rgb.txt"])
-+
- AC_DEFINE_UNQUOTED(X11_RGBFILE, "$rgb_file", [where rgb.txt is in])
-
- AC_MSG_CHECKING([for Compiler version])
diff --git a/kde-base/kdelibs/files/kdelibs-3.5.3-konqcrash.patch b/kde-base/kdelibs/files/kdelibs-3.5.3-konqcrash.patch
deleted file mode 100644
index 13ec8de97f8d..000000000000
--- a/kde-base/kdelibs/files/kdelibs-3.5.3-konqcrash.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: khtml/dom/dom_node.cpp
-===================================================================
---- khtml/dom/dom_node.cpp (revision 562181)
-+++ khtml/dom/dom_node.cpp (revision 562182)
-@@ -273,7 +273,7 @@
- NodeImpl *r = impl->replaceChild( newChild.impl, oldChild.impl, exceptioncode );
- if (exceptioncode)
- throw DOMException(exceptioncode);
-- if (!newChild.impl->closed()) newChild.impl->close();
-+ if (newChild.impl && !newChild.impl->closed()) newChild.impl->close();
- return r;
- }
-