summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/dcoppython')
-rw-r--r--kde-base/dcoppython/ChangeLog8
-rw-r--r--kde-base/dcoppython/dcoppython-3.5.5.ebuild28
-rw-r--r--kde-base/dcoppython/files/dcoppython-3.5.5-python-2.5-compat.diff11
-rw-r--r--kde-base/dcoppython/files/digest-dcoppython-3.5.53
4 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/dcoppython/ChangeLog b/kde-base/dcoppython/ChangeLog
index 193fc4c4794d..582de1cc0bcf 100644
--- a/kde-base/dcoppython/ChangeLog
+++ b/kde-base/dcoppython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/dcoppython
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dcoppython/ChangeLog,v 1.34 2006/10/03 08:58:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dcoppython/ChangeLog,v 1.35 2006/10/22 15:17:38 carlo Exp $
+
+*dcoppython-3.5.5 (22 Oct 2006)
+
+ 22 Oct 2006; Carsten Lohrke <carlo@gentoo.org>
+ +files/dcoppython-3.5.5-python-2.5-compat.diff, +dcoppython-3.5.5.ebuild:
+ Python 2.5 compatibility.
03 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
dcoppython-3.5.0.ebuild:
diff --git a/kde-base/dcoppython/dcoppython-3.5.5.ebuild b/kde-base/dcoppython/dcoppython-3.5.5.ebuild
new file mode 100644
index 000000000000..e9f6463e0f72
--- /dev/null
+++ b/kde-base/dcoppython/dcoppython-3.5.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dcoppython/dcoppython-3.5.5.ebuild,v 1.1 2006/10/22 15:17:38 carlo Exp $
+
+KMNAME=kdebindings
+KM_MAKEFILESREV=1
+MAXKDEVER=3.5.5
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE: Python bindings for DCOP"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND="virtual/python"
+
+# Because this installs into /usr/lib/python2.3/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely
+SLOT="0"
+
+PATCHES="$FILESDIR/no-gtk-glib-check.diff
+ ${FILESDIR}/dcoppython-3.5.5-python-2.5-compat.diff"
+
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}
+
diff --git a/kde-base/dcoppython/files/dcoppython-3.5.5-python-2.5-compat.diff b/kde-base/dcoppython/files/dcoppython-3.5.5-python-2.5-compat.diff
new file mode 100644
index 000000000000..2b3060710719
--- /dev/null
+++ b/kde-base/dcoppython/files/dcoppython-3.5.5-python-2.5-compat.diff
@@ -0,0 +1,11 @@
+--- dcoppython/shell/marshaller.cpp 2005/07/26 18:54:59 438982
++++ dcoppython/shell/marshaller.cpp 2006/10/03 15:28:22 592000
+@@ -124,7 +124,7 @@
+ if (!PyDict_Check(obj)) return false;
+
+
+- int c=0;
++ ssize_t c=0;
+ PyObject *key, *val;
+ while (PyDict_Next(obj, &c, &key, &val)==1)
+ if (!key_type.isMarshallable(key) ||
diff --git a/kde-base/dcoppython/files/digest-dcoppython-3.5.5 b/kde-base/dcoppython/files/digest-dcoppython-3.5.5
new file mode 100644
index 000000000000..d6542e599565
--- /dev/null
+++ b/kde-base/dcoppython/files/digest-dcoppython-3.5.5
@@ -0,0 +1,3 @@
+MD5 e0da219943407a786c2ceea1605fadd1 kdebindings-3.5.5.tar.bz2 5419613
+RMD160 8515555111e2745f63b403d3255ff5521bf77875 kdebindings-3.5.5.tar.bz2 5419613
+SHA256 54751d3fe6635abf7bb8ef08ff240354e56dfaaa02cd16b1dd2a837706c4b274 kdebindings-3.5.5.tar.bz2 5419613