summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/orbit')
-rw-r--r--gnome-base/orbit/ChangeLog7
-rw-r--r--gnome-base/orbit/Manifest10
-rw-r--r--gnome-base/orbit/files/digest-orbit-2.12.41
-rw-r--r--gnome-base/orbit/orbit-2.12.4.ebuild42
4 files changed, 55 insertions, 5 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index d1070d7da01e..8084115a6991 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.31 2005/08/16 20:33:40 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.32 2005/09/11 14:08:36 cretin Exp $
+
+*orbit-2.12.4 (11 Sep 2005)
+
+ 11 Sep 2005; Stefan Jones <cretin@gentoo.org> +orbit-2.12.4.ebuild:
+ Added orbit-2.12.4 for gnome-vfs-2.12.0
*orbit-2.12.3 (16 Aug 2005)
diff --git a/gnome-base/orbit/Manifest b/gnome-base/orbit/Manifest
index 4a67cd20d171..cf8aac336051 100644
--- a/gnome-base/orbit/Manifest
+++ b/gnome-base/orbit/Manifest
@@ -1,9 +1,11 @@
-MD5 ab4fc0545ddd4b93ba573707ee9f25a5 ChangeLog 3655
+MD5 3755188eb307350db5283ade24cb4f19 ChangeLog 3794
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 6f6fa3795d0324df35315d2215d55248 orbit-0.5.17.ebuild 1650
-MD5 d91e9619efdf905725f829843705f5e3 orbit-2.12.3.ebuild 1075
MD5 e3a8dc018eb029f302884b2fc80adf56 orbit-2.12.2.ebuild 1017
+MD5 d91e9619efdf905725f829843705f5e3 orbit-2.12.3.ebuild 1075
+MD5 fec6516c19ae8ef845a84da2f323d6d7 orbit-2.12.4.ebuild 1072
MD5 51bfc1efb763de186ee1b1f1e594891a files/digest-orbit-0.5.17 66
-MD5 855e570b505cfbb5e8748ba5baf471bc files/digest-orbit-2.12.3 66
-MD5 66a18f0f92e9cd0f658690bf1e5c862c files/digest-orbit-2.12.2 66
MD5 7105f3bdc076c48f0458e20ea8eaba34 files/orbit-0.5.17-m4.patch 472
+MD5 66a18f0f92e9cd0f658690bf1e5c862c files/digest-orbit-2.12.2 66
+MD5 855e570b505cfbb5e8748ba5baf471bc files/digest-orbit-2.12.3 66
+MD5 baa740810613ffcd2d1af90c6c82765f files/digest-orbit-2.12.4 66
diff --git a/gnome-base/orbit/files/digest-orbit-2.12.4 b/gnome-base/orbit/files/digest-orbit-2.12.4
new file mode 100644
index 000000000000..140b7f8ecc67
--- /dev/null
+++ b/gnome-base/orbit/files/digest-orbit-2.12.4
@@ -0,0 +1 @@
+MD5 aa2cae6e7957c369edccbd98ba78dea9 ORBit2-2.12.4.tar.bz2 676951
diff --git a/gnome-base/orbit/orbit-2.12.4.ebuild b/gnome-base/orbit/orbit-2.12.4.ebuild
new file mode 100644
index 000000000000..a618e5c911ca
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.12.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.12.4.ebuild,v 1.1 2005/09/11 14:08:36 cretin Exp $
+
+inherit gnome2
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc ssl static"
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/popt-1.5
+ >=dev-libs/libIDL-0.8.2
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+# FIXME linc is now integrated, but a block isn't necessary
+# and probably complicated FIXME
+
+# FIXME ssl is optional, but not switchable
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.14
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+USE_DESTDIR="1"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+
+pkg_setup() {
+ G2CONF="$(use_enable static)"
+}