summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/xu4/xu4-0.9.ebuild')
-rw-r--r--games-rpg/xu4/xu4-0.9.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/games-rpg/xu4/xu4-0.9.ebuild b/games-rpg/xu4/xu4-0.9.ebuild
index 2fb4adbc3ead..cee72813de8d 100644
--- a/games-rpg/xu4/xu4-0.9.ebuild
+++ b/games-rpg/xu4/xu4-0.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/xu4/xu4-0.9.ebuild,v 1.4 2004/10/22 11:30:34 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/xu4/xu4-0.9.ebuild,v 1.5 2006/12/21 23:29:29 tupone Exp $
inherit eutils games
@@ -24,6 +24,14 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/u4"
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-mixer timidity ; then
+ eerror "${PN} needs sdl-mixer compiled with timidity use-flag enabled!"
+ die "sdl-mixer without timidity detected"
+ fi
+ games_pkg_setup
+}
+
src_unpack() {
# xu4 will read the data files right out of the zip files
# but we want the docs from the original.