summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/egoboo/egoboo-2.22.ebuild')
-rw-r--r--games-rpg/egoboo/egoboo-2.22.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/games-rpg/egoboo/egoboo-2.22.ebuild b/games-rpg/egoboo/egoboo-2.22.ebuild
index 01aa3c289917..4284ece1843c 100644
--- a/games-rpg/egoboo/egoboo-2.22.ebuild
+++ b/games-rpg/egoboo/egoboo-2.22.ebuild
@@ -1,18 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/egoboo-2.22.ebuild,v 1.4 2004/02/15 14:36:45 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/egoboo/egoboo-2.22.ebuild,v 1.5 2004/02/29 21:09:29 vapier Exp $
inherit flag-o-matic games
-S="${WORKDIR}/${PN}"
DESCRIPTION="A 3d dungeon crawling adventure in the spirit of NetHack"
HOMEPAGE="http://egoboo.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/ego${PV/./}.tar.gz"
-KEYWORDS="-* x86 ~ppc"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
+KEYWORDS="-* x86 ppc"
DEPEND="virtual/x11
virtual/opengl
@@ -20,9 +18,10 @@ DEPEND="virtual/x11
media-libs/libsdl
>=sys-apps/sed-4"
+S=${WORKDIR}/${PN}
+
src_unpack() {
- replace-flags "-march=athlon*" "-march=i686"
- replace-flags "-march=pentium4" "-march=i686"
+ replace-cpu-flags i686 'athlon*' pentium4
unpack ${A}
cd ${S}
@@ -30,7 +29,7 @@ src_unpack() {
sed -i \
-e "/^CC=/ s:=.*:=${CC}:" \
-e "s:-ffast-math -funroll-loops -O3 -g:${CFLAGS}:" code/Makefile \
- || die "sed code/Makefile failed"
+ || die "sed code/Makefile failed"
sed \
-e "s:GENTOODIR:${GAMES_DATADIR}:" "${FILESDIR}/${P}.sh" \
> "${T}/egoboo" || die "sed wrapper failed"