summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/biniax2/ChangeLog11
-rw-r--r--games-puzzle/biniax2/Manifest17
-rw-r--r--games-puzzle/biniax2/biniax2-1.30.ebuild41
-rw-r--r--games-puzzle/biniax2/files/biniax2-1.30-build.patch18
-rw-r--r--games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch60
-rw-r--r--games-puzzle/biniax2/files/biniax2.xpm41
-rw-r--r--games-puzzle/biniax2/metadata.xml5
7 files changed, 193 insertions, 0 deletions
diff --git a/games-puzzle/biniax2/ChangeLog b/games-puzzle/biniax2/ChangeLog
new file mode 100644
index 000000000000..94ff23fdb4c7
--- /dev/null
+++ b/games-puzzle/biniax2/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-puzzle/biniax2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/biniax2/ChangeLog,v 1.1 2009/11/05 18:31:24 nyhm Exp $
+
+*biniax2-1.30 (05 Nov 2009)
+
+ 05 Nov 2009; Tristan Heaven <nyhm@gentoo.org> +biniax2-1.30.ebuild,
+ +files/biniax2-1.30-build.patch, +files/biniax2-1.30-dotfiles.patch,
+ +files/biniax2.xpm, +metadata.xml:
+ Initial commit
+
diff --git a/games-puzzle/biniax2/Manifest b/games-puzzle/biniax2/Manifest
new file mode 100644
index 000000000000..401dd40f7cfd
--- /dev/null
+++ b/games-puzzle/biniax2/Manifest
@@ -0,0 +1,17 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX biniax2-1.30-build.patch 525 RMD160 9b207fe9c15090f09dd558a520d0a689222b759d SHA1 f6a6648ee1c220e6181b4d7cd08cdd1175aee28f SHA256 1a83cc66417f5c0f1b80da6a747ea700469170b9176f7fe21da692d649afbac7
+AUX biniax2-1.30-dotfiles.patch 1356 RMD160 be5f25b9fe496a57e00907eedc4822be6bfd4376 SHA1 875632e79195bbd64f1a2d927b4ca935bb68b346 SHA256 b613328a03a54b32c1a00401e94f6f17ecc7a3a332ec370f404a25157671f57a
+AUX biniax2.xpm 1292 RMD160 a5beef47f26291be2773f05d2630fcdb584e6d14 SHA1 119f71708ec7f437067f52f4b139d97f03b866ca SHA256 0851b1dbd8e0dbcbaa9bb248b7f6e9490391f491f590686382e27500648ba7ec
+DIST biniax2-1.30-fullsrc.tar.gz 3072220 RMD160 a89d401ca682a8e26f9d80b9060b90ea86f0ca1d SHA1 28fee9477df30a39e9be5c0b53ea16c888b91e86 SHA256 2c09f6f0a5fe453a409d990d72a964636ee91ca91daac99f0db861b8f42531bf
+EBUILD biniax2-1.30.ebuild 988 RMD160 a2cc54cf9b83b962f1c1bcefbc50e8d76ddbec3c SHA1 32da88ee0b2081b1ba91084a4ea721f9f96d7a80 SHA256 3771d0001de3cd8c3be975ac55e6b007bb3368a217c21d1caab2f233db5fa151
+MISC ChangeLog 436 RMD160 0288c47a535ed83dbe9216a237016e913cfb3594 SHA1 403947cea248427401127a1490a579e2e1f167dc SHA256 ffe84a84ee3134f70a854addf0e5211c011128ba306718aabd36502d15b51d9c
+MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.12 (GNU/Linux)
+
+iEYEARECAAYFAkrzGgAACgkQdz7hIScOURGGQgCgl6hmhspRtMJKi8vCU63hptSU
+6S0An3Is+1nxVdNXWXt5W3zvLVK00BYz
+=Cxse
+-----END PGP SIGNATURE-----
diff --git a/games-puzzle/biniax2/biniax2-1.30.ebuild b/games-puzzle/biniax2/biniax2-1.30.ebuild
new file mode 100644
index 000000000000..375fde0e420b
--- /dev/null
+++ b/games-puzzle/biniax2/biniax2-1.30.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/biniax2/biniax2-1.30.ebuild,v 1.1 2009/11/05 18:31:24 nyhm Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Logic game with arcade and tactics modes"
+HOMEPAGE="http://biniax.com/"
+SRC_URI="http://mordred.dir.bg/biniax/${P}-fullsrc.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mikmod]"
+
+S=${WORKDIR}
+
+src_prepare() {
+ rm -f data/Thumbs.db
+ sed -i \
+ -e "s:data/:${GAMES_DATADIR}/${PN}/:" \
+ desktop/{gfx,snd}.c \
+ || die "sed failed"
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-dotfiles.patch
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/* || die "doins failed"
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry ${PN} Biniax-2
+ prepgamesdirs
+}
diff --git a/games-puzzle/biniax2/files/biniax2-1.30-build.patch b/games-puzzle/biniax2/files/biniax2-1.30-build.patch
new file mode 100644
index 000000000000..26c053c2e98e
--- /dev/null
+++ b/games-puzzle/biniax2/files/biniax2-1.30-build.patch
@@ -0,0 +1,18 @@
+--- makefile
++++ makefile
+@@ -4,7 +4,7 @@
+ # To execute the game you need the runtimes of SDL, SDL_mixer and SDL_image.
+
+ FLAGS=-W -WALL
+-CC=gcc
++CC?=gcc
+ FILES=biniax.c hof.c desktop/cfg.c desktop/gfx.c desktop/snd.c desktop/inp.c desktop/sys.c
+ INCLUDES=-I . -I desktop
+ LINKTO=-lSDL -lSDL_mixer -lSDL_image
+@@ -12,4 +12,4 @@
+ TARGET=biniax2
+
+ biniax:
+- $(CC) $(AUTO) $(FILES) $(INCLUDES) -o $(TARGET) $(LINKTO)
+\ No newline at end of file
++ $(CC) $(CFLAGS) $(LDFLAGS) $(AUTO) $(FILES) $(INCLUDES) -o $(TARGET) $(LINKTO)
diff --git a/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch b/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch
new file mode 100644
index 000000000000..2cd212d6857c
--- /dev/null
+++ b/games-puzzle/biniax2/files/biniax2-1.30-dotfiles.patch
@@ -0,0 +1,60 @@
+--- biniax.c
++++ biniax.c
+@@ -47,6 +47,8 @@
+ INCLUDES
+ ******************************************************************************/
+
++#include <unistd.h>
++
+ #include "game.h"
+ #include "lev.h"
+ #include "inc.h"
+@@ -97,6 +99,8 @@
+ UNREF( argc );
+ UNREF( argv );
+
++ chdir( getenv( "HOME" ) );
++
+ cfgInit();
+ hofInit();
+ if ( gfxInit() == BNX_FALSE )
+--- desktop/cfg.c
++++ desktop/cfg.c
+@@ -36,7 +36,7 @@
+ ******************************************************************************/
+
+ #define _Cfg_Buffer 255
+-#define csConfigName "config.bnx2"
++#define csConfigName ".config.bnx2"
+
+ struct BNX_SETUP
+ {
+--- game.h
++++ game.h
+@@ -37,7 +37,7 @@
+ DEFINITIONS
+ ******************************************************************************/
+
+-#define csSaveGameName "autosave.bnx2"
++#define csSaveGameName ".autosave.bnx2"
+
+ /******************************************************************************
+ CONSTANTS
+--- hof.c
++++ hof.c
+@@ -34,7 +34,7 @@
+ #define chCursor '_' /* Cursor ON */
+ #define chSpace ' ' /* Cursor OFF*/
+
+-#define csHOFName "hof.bnx2" /* File name */
++#define csHOFName ".hof.bnx2" /* File name */
+ #define cHOFFileSize 504 /* File size */
+
+ BNX_HALL Hof;
+@@ -292,4 +292,4 @@
+ BNX_HALL *hofGet()
+ {
+ return (BNX_HALL *) &Hof;
+-}
+\ No newline at end of file
++}
diff --git a/games-puzzle/biniax2/files/biniax2.xpm b/games-puzzle/biniax2/files/biniax2.xpm
new file mode 100644
index 000000000000..da3c5ddd7d1d
--- /dev/null
+++ b/games-puzzle/biniax2/files/biniax2.xpm
@@ -0,0 +1,41 @@
+/* XPM */
+static char * icon_xpm[] = {
+"32 32 6 1",
+" c None",
+". c #800000",
+"+ c #FF8204",
+"@ c #FC4E04",
+"# c #FCA204",
+"$ c #FEC489",
+" ",
+" ",
+" ",
+" . ",
+" ++++++++++ .@. ",
+" +########$ .@@@$ ",
+" +#$$$$$$$$ $@$ ",
+" +#$ $ ",
+" +#$ ",
+" +#$ ",
+" +#$ ++++ +++ +++ ",
+" +#$ +#### +#$ +#$ ",
+" +#$ +####+ +#$ +#$ ",
+" +#$ +#$#### +#$ +#$ ",
+" +#$ +#$ $##+ +#$ +#$ ",
+" +#$ +#$ #### +#$ +#$ ",
+" +#$ +#$ $##+ +#$ +#$ ",
+" +#$ +#$ #### +#$ +#$ ",
+" +#$ +#$ $##+ +#$ +#$ ",
+" +#$ +#$ ######$ +#$ ",
+" +#$ +#$ $####$ +#$ ",
+" +#$ +#$ ####$ +#$ ",
+" $$$ $$$ $$$$ +#$ ",
+" +#$ ",
+" +#$ ",
+" . +#$ ",
+" .@. ++++++++#$ ",
+" .@@@$ +########$ ",
+" $@$ $$$$$$$$$$ ",
+" $ ",
+" ",
+" "};
diff --git a/games-puzzle/biniax2/metadata.xml b/games-puzzle/biniax2/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/biniax2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>